Strafing problem



  • Yup, i can’t strafe. So that means i can’t play this game. I do have the steam version (if you can even get it anywhere else). Yes

    I HAVE TRIED THE /CONFIG Udkgame.ini fixes. They do not work.
    For one thing, the lines that people say to change… aren’t there. They aren’t in the .ini file, anywhere. I have “verified the game cache”. I have tried screwing with the .ini files. Nothing seems to work.
    The “strafe” input option … isn’t there when im ingame either.

    In summation: Fix bugs BEFORE content guys. And if you’re going to release a patch, at least make sure the basic mechanics are ironed out. Tired of devs not doing their homework.



  • So you are saying you can’t move to the left or right? Or only while attacking? Always?



  • I can turn left and right, but can’t move left or right. Always.



  • @itchy01ca:

    I can turn left and right, but can’t move left or right. Always.

    Oh I see other people are having this problem if they play with the arrows. I take it you don’t use WSAD?



  • Nope. I started on arrows back in the late 80s. Hard to switch it up now.



  • @itchy01ca:

    Nope. I started on arrows back in the late 80s. Hard to switch it up now.

    Ok well at least now we know the problem across the board. I have no solution at the moment, but will make sure this problem is heard.



  • Ok just verified something for myself and for others. WASD strafing does work. If you keep the same config, strafing does work. But when you change the keys to arrow keys, suddenly the game thinks you mean “turn” not “strafe”. Very odd.



  • @itchy01ca:

    Ok just verified something for myself and for others. WASD strafing does work. If you keep the same config, strafing does work. But when you change the keys to arrow keys, suddenly the game thinks you mean “turn” not “strafe”. Very odd.

    Yeah I tested it too right now. Indeed the case.



  • Got it to work now. Did this:

    Open UDKGame.ini in C:\Users\blabla\Documents\My Games\Chivalry Medieval Warfare\Config

    Goto text [UTGame.UTPlayerInput]
    below there are the text lines:
    Bindings=(Name=“Left”,SecondaryKey=,Command=“GBA_AOCLeft” …
    Bindings=(Name=“Right”,SecondaryKey=,Command=“GBA_AOCRight” …

    Make sure the Bindings Command for Left and Right only says “GBA_AOCLeft” or “GBA_AOCRight” and delete the |GBA_Turn if necessary e.g. “GBA_AOCLeft|GBA_TurnHamster” to “GBA_AOCLeft”

    It seems the turn left command was conflicting with the strafe command on the arrow keys.


Log in to reply