Keybinds are corrupted after editing them



  • Hi! :D

    1. Open the keybinds window
    2. Reset it
    2. Change Move Left to “Z”
    3. Change Move Right to “P”
    4. Save
    5. Reopen the keybinds window

    What happens:

    1. some keybinds are rearranged
    • Tactical messages is now at the top
    • Next Camer View is now at the top
      (I didn’t check the whole list)
    1. some instances of “?INT?AOCKeybinds.Keybinds…”
    • see the screenshot

    I am using Windows 7 64bit and just installed the game today

    Cheers! :D



  • BUMP!

    I’m still seeing this after the latest update.



  • I’m not sure what you are asking for, but you can reset everything to defaults by deleting your Chivalry folder from Documents\My Games.



  • I think it’s a bug or 2 bugs… when I try to configure the controls, those weird things happen.

    I see “?INT?AOCKeybinds.Keybinds…” (see the screenshot above) and I don’t know what that it said before

    I deleted the Chivalry folder but it still happens.

    Can’t find a workaround…



  • @ReMixx:

    I’m not sure what you are asking for, but you can reset everything to defaults by deleting your Chivalry folder from Documents\My Games.

    I already posted this and also a workaround for this.

    viewtopic.php?f=69&t=7024

    viewtopic.php?f=69&t=6996

    It is very easy to reproduce. Did u try it??
    Deleting the Folder doesn’t really help.
    Bug 1:
    After setting the binds, they are screwed up in game.

    Bug 2:
    Resetting the binds leads to 2 messed up strings

    Bug 3:
    Deleting the bind of the two turn commands (which strings are messed up) does not work, only assigning them to another key.



  • @ReMixx:

    I’m not sure what you are asking for, but you can reset everything to defaults by deleting your Chivalry folder from Documents\My Games.

    Oh and what he is aksing for is obviously a bugfree keybinding, which is indeed quite important for that game ^^



  • could someone please confirm, that this issue is beeing worked on???



  • honestly, I am currently loosing faith in this game…
    First the 1h weapons are completely overpowered, second, the weird lags that appear to everyone and were discussed many times in this forum and torn appart by the admins and thrid the key binding thing that no one ever tried to reproduce like it seems!!!



  • I followed the workaround from here viewtopic.php?f=69&t=6037&hilit=keybind#p49270

    In UDKInput.ini, I removed these:

    Bindings=(Name=“Left”,Command=“GBA_TurnLeft”,Flag=“KBFlag_Movement”,FriendlyName=“TurnLeft”)
    Bindings=(Name=“Right”,Command=“GBA_TurnRight”,Flag=“KBFlag_Movement”,FriendlyName=“TurnRight”)

    and it almost fixes the “?INT?AOCKeybinds.Keybinds…” issue, I see it now only once, before it was worse :-|



  • Push!!
    Can some developer/admin confirm this issue as a bug?



  • Not fixed in the January Steam update.

    If it helps the devs: I’m using Logitech G5 mouse, MS Multimedia Keyboard


Log in to reply