Gamepad



  • Recently installed Chivalry (because of some of the cracking reviews i read!)

    I want to use my gamepad (its just a basic PS2 imitation game pad for the PC) but i cannot get Chivalry to pick it up. The game runs fine and the mouse controls are fine.

    I’ve gone into Keybinds but it will not let me enter anything for my game-pad.

    The gamepad works fine on other games, just not this one!

    Any suggestions?



  • Effect wrote:
    Several threads already openened with this issue.
    In Short:

    • Verify your Steam Cache
    • Delete Chivalry Folder in the Folder My Games in My Documents
    • Set all the binds
    • When in Game verify if they work, if not set again
      –> Should work

    This may help somehow.Looks like the keybind issues.



  • Hi, thank you for the reply.

    Have tried the suggestions, don’t appear to have worked.

    With regards to the keybind, because the game isn’t picking up my gamepad i can’t alter any of the controls to my gamepad, so effectively all i can do is alter the keybinds to alternative keyboard inputs.

    Usually i would just use the kbm but as i am a laptop i would find it easier to use a gamepad.

    Thanks.



  • You may need to run an Xbox controller emulator to have Chiv see it as an Xbox360 controller:

    http://code.google.com/p/x360ce/



  • Thanks for the replies, have installed the emulator and assigned keys, still get the same problem, won’t recognize my game pad so wont allow me to input anything game pad related into the key bind.

    Shame because the game looks great!



  • @grimmy00:

    Thanks for the replies, have installed the emulator and assigned keys, still get the same problem, won’t recognize my game pad so wont allow me to input anything game pad related into the key bind.

    Shame because the game looks great!

    You put the the files here? C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32

    Did you follow these instructions? http://code.google.com/p/x360ce/wiki/MainPage



  • Yeah the emulator created the file xinput1_3.dll which is in the location stated above. Still no joy.

    Maybe just fork out for a usb lead for my xbox 360 controller!!!?

    Appreciate the help guys.



  • @grimmy00:

    Yeah the emulator created the file xinput1_3.dll which is in the location stated above. Still no joy.

    Did you try this?

    Installation
    Run this program from game executable directory. Game executable can look for xinput dll by different names, you can create copy of dll with name provided below till you find one that works:

    xinput1_3.dll
    xinput1_2.dll
    xinput1_1.dll
    xinput9_1_0.dll



  • Tried them all my friend to no avail.

    I have attached a screenshot of the xbox emulator to make sure i am doing it right.

    Once again thanks for trying to help me.



  • I threw my old controller away so I can’t really test it to verify :( I vaguely remember something about saving a database file in one of the tabs. Did you do anything like that?



  • This is a simple reply, but make sure it is in Xinput if it is a logitech gamepad F310 (or others I don’t know about with such an option). :P


Log in to reply