Tremendous lag



  • Hi everyone !

    I just bought Chivalry on Steam today, donwload and setup worked fine. But when I launch the game, it lags a lot. I mean, even the menus are lagging and the practice mode is totally unplayable.
    For info I have an Asus N53S with Intel i3 processor (2.3 GHz), 4 Gb RAM and a Nvidia Geforce GT550M (2Gb). I know it is not a warmachine but, for exemple, Assassin’s Creed Brotherhood or F1 2012 runs very well. I tried to set the resolution to minimum, it reduces the problem but it is still unplayable.

    Someone already faced that problem ? Is it a Steam related problem ?

    Thank you for answering, and forgive my mistakes,I’m not a native English speaker :D



  • @fulladrenaline:

    Hi everyone !

    I just bought Chivalry on Steam today, donwload and setup worked fine. But when I launch the game, it lags a lot. I mean, even the menus are lagging and the practice mode is totally unplayable.
    For info I have an Asus N53S with Intel i3 processor (2.3 GHz), 4 Gb RAM and a Nvidia Geforce GT550M (2Gb). I know it is not a warmachine but, for exemple, Assassin’s Creed Brotherhood or F1 2012 runs very well. I tried to set the resolution to minimum, it reduces the problem but it is still unplayable.

    Someone already faced that problem ? Is it a Steam related problem ?

    Thank you for answering, and forgive my mistakes,I’m not a native English speaker :D

    Hello! Would you please attach your DxDiag.txt?



  • Here is my DxDiag :)



  • Make sure the game runs with your Nvidia graphic card and not the integrated graphics. Search on the forum it’s been discussed a zillion times already…

    Edit for instructions:

    Nvidia control panel (on the desktop) - Manage 3D Settings - Program Settings - Select a program to customize - Add UDK.exe - High Performance Graphic Processor - Apply



  • @fulladrenaline:

    For info I have an Asus N53S with Intel i3 processor (2.3 GHz)

    Processor: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz (4 CPUs), ~2.3GHz
    

    I think that you meant Intel i5? :)

    See this thread to make sure that you are using the nvidia GPU instead of the integrated one with UDK.exe: viewtopic.php?f=69&t=3830&hilit=high+performance+step+2


Log in to reply