Bug Report: Log: UDP recvfrom error:



  • When starting a dedicated server (version 10246 - the most recent hotfix at this date) the following error appears in the server log:

    [0009.11] Log: UDP recvfrom error: 183 (Unknown Error) from 0.0.0.0:0
    

    This is the command line from the server log:

    Init: Command line: SERVER AOCTO-Battlegrounds_v3_P?steamsockets -seekfreeloadingserver -multihome=203.46.105.32 -port=20590 -log=20590\server.log -configsubdir=20590 -maxplayers=32 
    

    The server with that log entry does not appear on the server list nor allow direct connections from clients.

    Omitting the -multihome switch from the command line resolves the issue. This is the command line from the log when the server starts successfully:

    Init: Command line: SERVER AOCTO-Battlegrounds_v3_P?steamsockets -seekfreeloadingserver -port=20590 -log=20590\server.log -configsubdir=20590 -maxplayers=32 
    

    For certainty, the ipconfig output for the server:

    IPv4 Address. . . . . . . . . . . : 203.46.105.32
    

    Another server on the same host launches correctly with the multihome switch on the command line. I have not confirmed if it is only the second server launched on the same host that has this issue as I do not want to restart customer servers for testing purposes.

    A developer from Torn Banner is welcome to contact me on the email address I used to register for this forum if they’d like me to send full server logs and any other information.