Chivalry Unplayable on Laptop



  • Hey so I got Chivalry last Tuesday to play over Thanksgiving Break, and gradually fell in love with the game. Now I want to play it at my dorms too, but it seems to be so laggy (even at the main menu) and choppy that it is unplayable…

    At my home I played on a GTX 560TI desktop, and the laptop in question right now is equipped with the A6-3420M + Radeon 7670M running in cross with 6520G. Now I’ve seen youtube videos of people running BF3 on Ultra with 1366 res with 40+ FPS with the exact same laptop and specs, and theoretically if it can run BF3 shouldn’t it also run Chivalry?

    After doing some research, the 7670M + 6520G combined should theoretically have at least the power of a GTX 660M, and be beyond the Radeon 5570 HD by far (which was my old desktop GPU before upgrade, able to run Red Orchestra 2 on 1920x1080 medium with ~25FPS).

    I mean it just makes no sense to me that an indie game like Chivalry should take more hardware power than Battlefield 3 or Red Orchestra 2 to run…What is causing the choppiness? There must be something else that’s wrong, not my hardware…

    Other games I have successfully run on laptop: Wargame: European Escalation, DayZ (though Arma 2 itself was so laggy it was unplayable, made no sense to me as DayZ ran perfectly >45 FPS), Empire: Total War, Left 4 Dead 2.



  • One possible solution from the support forum.

    viewtopic.php?f=69&t=3830

    Make sure Chivalry is using your Dedicated Video Card, not the chipset graphics.



  • @Andrew:

    One possible solution from the support forum.

    viewtopic.php?f=69&t=3830

    Make sure Chivalry is using your Dedicated Video Card, not the chipset graphics.

    How do I make sure that it is doing so?



  • Also, the thread you posted makes even less sense to me. My card is more powerful than the GTX 540M!!! Where is my 30-40 FPS :(



  • @ericdude88:

    Also, the thread you posted makes even less sense to me. My card is more powerful than the GTX 540M!!! Where is my 30-40 FPS :(

    Post Number 8 in the thread I linked has pictures on how to do it for an Nvidia card.



  • @Andrew:

    @ericdude88:

    Also, the thread you posted makes even less sense to me. My card is more powerful than the GTX 540M!!! Where is my 30-40 FPS :(

    Post Number 8 in the thread I linked has pictures on how to do it for an Nvidia card.

    Yeah…but I have an ATI card… :(



  • Oh, sorry, was looking at the desktop card.

    AMD

    https://www.youtube.com/watch?v=NVDiN06fiOU

    Catalyst Control Center. Make sure your drivers are all up to date. You need to enable performance mode for UDK.exe/Chivalry.

    EDIT: Shorter vid.

    https://www.youtube.com/watch?v=4oB2oDO … ure=fvwrel



  • Alright thanks alot gonna try it.



  • Does not work :(
    I cannot start the AMD VISION Engine Control Center, I get the error “AMD VISION ENGINE CONROL CENTER cannot be started. There are currently no settings that can be configured using AMD VISION Engine Control Center…”



  • Check and make sure your drivers are all up to date. Steam has an auto update option under the steam menu. If that fails, I would grab the latest drivers from the laptop manufacturer site. Never had a laptop with switchable graphics myself, so I have limited knowledge on how their drivers work compared to their desktop counter part.

    It sounds like catalyst is recognizing the chipset rather than the amd card for some reason, which is puzzling.



  • If you can manage it, try to run the game ONLY using the dedicated graphics card (7670) und NOT both cards in Crossfire. There is such a big performance gap between both that combining them could raise the framerate slightly indeed, but rather will caus so called micro stuttering.



  • Had a huge FPS problem too with my laptop. Could you tell us how many fps you get at the moment and whether it goes up and down? More importantly, does it make a difference at all in term of FPS when you switch all the graphics settings from very high to very low? Lastly, what is the clock of your processor and does it have a turbo boost (or is it manually overclocked by you?) I may be able to assist you since I had a problems paying chiv with my laptop and now it works well with lower specs than yours (40-60 FPS).



  • @unholy:

    Had a huge FPS problem too with my laptop. Could you tell us how many fps you get at the moment and whether it goes up and down? More importantly, does it make a difference at all in term of FPS when you switch all the graphics settings from very high to very low? Lastly, what is the clock of your processor and does it have a turbo boost (or is it manually overclocked by you?) I may be able to assist you since I had a problems paying chiv with my laptop and now it works well with lower specs than yours (40-60 FPS).

    I get a stable fps that ranges between 14 and 20, and it does not change very much (maybe a 5 fps change) if I change from very high to very low. I think my processor is 2.4 GHZ and it has a Turbo CORE technology, but I didn’t overclock it or anything.
    Please help!



  • @Andrew:

    Check and make sure your drivers are all up to date. Steam has an auto update option under the steam menu. If that fails, I would grab the latest drivers from the laptop manufacturer site. Never had a laptop with switchable graphics myself, so I have limited knowledge on how their drivers work compared to their desktop counter part.

    It sounds like catalyst is recognizing the chipset rather than the amd card for some reason, which is puzzling.

    When I do the auto-checking thing through device manager it says everything is up-to-date. I don’t know if I should trust that mechanic though, but I know of no other way to check if things are up to date, nor do I know where to find the latest drivers for my specific cards (The AMD website is hella confusing…I don’t even know what I downloaded last time I tried to update there, whereas NVIDIA actually has an autochecker…)



  • @MadManniMan:

    If you can manage it, try to run the game ONLY using the dedicated graphics card (7670) und NOT both cards in Crossfire. There is such a big performance gap between both that combining them could raise the framerate slightly indeed, but rather will caus so called micro stuttering.

    While micro stuttering is synonymous with multi gpu setups, it’s not 100% guaranteed that he’ll experience it.



  • @venomblade:

    While micro stuttering is synonymous with multi gpu setups, it’s not 100% guaranteed that he’ll experience it.

    The larger the performance gap between between AFR rendering GPUs the more likely the micro stuttering.



  • @MadManniMan:

    If you can manage it, try to run the game ONLY using the dedicated graphics card (7670) und NOT both cards in Crossfire. There is such a big performance gap between both that combining them could raise the framerate slightly indeed, but rather will caus so called micro stuttering.

    Hey man thanks for the suggestion. But I have no clue how to use only the dedicated GPU. I tried disabling my 6520G in the Device Manager while leaving the 7670M there enabled, but all that did was make everything look like crap (even my desktop, with a max res of 1024 x some small #), and make Chivalry unrunnable, as in when I try to start it up it says unable to run because “Your videocard does not support alpha blending with floating point render targets” and exits automatically…

    So I have no idea how to run the 7670M alone…Disabling 6520G just makes me run in no graphics card mode… :(



  • Try this. Make sure you are using high performance profile in your power options. now go to change plan setting and then advanced plan settings. Under processor power management, make sure the active cooling policy is set to active. Then, in both minimum and maximum processor state put 99% instead of whatever was there (normaly 0 or 100% depending on the default profile).

    The reason for that is that turbo boost is bugged on many systems. If it does fix your fps (you should be getting around 50fps), you could either leave everything at 99% which will just disable your turbo, or you can check if there is a new bios for you rig that will resolve the issue.



  • I am/was always on the high performance power state. I went into the advanced options, and everything has been 100%, and the 2 cooling options are both on.

    I mean, I’m 100% sure that the problem is solely caused by my laptop refusing to use dedicated GPU. If someone can tell me how to fix that, that’ll be great.



  • In the power tab of CCC do you have “Enable Powerplay” on?


Log in to reply