Norse Sword Doesnt exist



  • All other weapons work fine.
    But my norse sword just wont do anything, I can swing at team mates and at enemies. Does not damage or anything. Other people see the swinging animation. It just does nothing



  • … does it happen on every server?



  • I was just on a duel server and 3 of us noticed this. The Norse Sword swings just fine, but it does no damage, it just goes through.
    I tried it on one of the official team objective servers and it was the same.



  • Aha! They finally nerfed it for being too overpowered :)

    Do the stab and overhead still do damage?



  • No, nothing. The animations play, but there’s no actual collision or damage.



  • Same here, the animation plays but no contact.

    I was swiping at an AFK for ages and nothing.



  • Can someone make a video of this? I am curious what is going on here. Does it happen all the time?



  • @ChuckingIt:

    Can someone make a video of this? I am curious what is going on here. Does it happen all the time?

    Please make a video of it and post to the YouTubes if you can that we can direct the devs to. I just tried a FFA game and the norse sword worked fine for all 3 attacks for both MAA and Knight. Does it matter what your secondary and tertiary weapons are?



  • This happens when your config file is different [somehow] than the server. Try playing on an official server as they should be running the right files. If it’s still happening, it’s something wrong locally Try deleting my documents\my games\chivalry medieval warfare\udkgame\config and try verifying your game cache.


Log in to reply