Game crash through Steam



  • I have a problem where when i enter the game through steam it can’t find any servers, and when i try to create a game my client crash. UDK.exe has stopped working. I have reinstalled the game and it didn’t help. I’ve tried opening the game without steam, but it won’t locate any serves, though the game doesn’t crash when i create a game.

    My PC specs are.

    Intel 2500K
    8Gb ram 1600 Mhz
    AMD 6970 gfx

    Thanks for the help :)



  • Please attach a Launch.log and DxDiag.txt.



  • Im sorry but i don’t follow :(



  • @MelvinTheHobo:

    Im sorry but i don’t follow :(

    Please reply to this thread with the following files attached to it.

    Launch.log can be found in C:\Users\dan\Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs.

    DxDiag.txt is created by clicking on the Start button, typing in dxdiag into the search box, opening dxdiag.exe, and clicking Save All Information once the app pops up. This will generate the text file.



  • Here you go :)



  • @MelvinTheHobo:

    Here you go :)

    That’s it, thanks!

    From your log file, it looked like you were playing in the tutorial. Did that work okay?

    Okay first suggestion. Please update your video card drivers as your current ones are from April.



  • The tutorial and create own game works when im not launching through steam, but when i launch through steam the client crash.

    I’ve updated my drivers now but i still doesn’t work



  • @MelvinTheHobo:

    The tutorial and create own game works when im not launching through steam, but when i launch through steam the client crash.

    I’ve updated my drivers now but i still doesn’t work

    Ok so when you Launch through Steam, it immediately crashes or can you get to the main menu in game? Also, please attach an updated DxDiag.txt :)



  • I can get to the main menu when i launch through steam.



  • @MelvinTheHobo:

    I can get to the main menu when i launch through steam.

    Okay and if you open the server browser and let it sit for a few minutes, nothing shows up, correct?

    If that is the case, try manually connecting to one of the Vanquish servers.

    Vanquish Servers:
    Vanquish - Saturday Knight Fever (Dallas) 32 slot [69.162.113.86:7777]
    Vanquish Thy Foes! TO & TD (Chicago) 24 slot [74.91.125.196:6000]
    Vanquish or Die! UK (UK) 18 slot [Coming soon]
    Vanquish - Duel Server (Chicago) 12 slot [74.91.124.229:6000]

    Open the in-game console (tilde key on English keyboards), type in “open 69.162.113.86:7777” without the quotes. Replace the IP address and port number with the server that you would like to try.



  • I tried but the game crashed again. It’s really weird because i’ve been playing the game since it came out but now suddenly it has stopped working :(



  • @MelvinTheHobo:

    I tried but the game crashed again. It’s really weird because i’ve been playing the game since it came out but now suddenly it has stopped working :(

    Try deleting the Documents\My Games\Chivalry Medieval Warfare folder. This will delete any custom keybinds or video settings. Try launching Chiv through Steam.

    If that doesn’t work, try running the two vcredist executable files in C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\RedistChiv and the DXSETUP.exe in the DXRedistCutdown folder. Try launching Chiv through Steam

    If that doesn’t work, try viewtopic.php?f=69&t=6174. Try launching Chiv through Steam.

    If you get any different behavior from any of those steps, report back!



  • I tried the last one where i delete the config folder, and then when i verify the integrity it says that 72 files could not be confirmed and will be downloaded. I’ve tried launching but it still crashes



  • I just checked. It just downloads the config folder again



  • @MelvinTheHobo:

    I just checked. It just downloads the config folder again

    Did it help?



  • Unfortunatly no



  • A completed launch.log showing errors would be helpful.



  • Here we go :)



  • @MelvinTheHobo:

    Here we go :)

    You can still get to and see the main menu in game???

    Because from your game log… ewwww!

    [0037.15] Log: === Critical error: ===
    Fatal error!
    
    Address = 0x1ca8146  (filename not found) [in D:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x12d91b5  (filename not found) [in D:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x1c8b299  (filename not found) [in D:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x12f938b  (filename not found) [in D:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    


  • I can press the “Join Game” and get to the overview of the servers.

    Haha that was comforting :D

    Do you think a reinstall would help?