Some of my friends can't join my server



  • Hello me and another friend have tried to put up a chivalry server and we both get the same problem.
    It shows up in the game list and random people is joining, so far so good.
    But when my friends try to join me only half of them can do it while the other gets stuck loading forever when they try to join my server.

    What can be the cause of this problem?
    Ports are open and all the config are as they should be and they tried to remove their firewall and open ports even though that shouldn’t be the problem.



  • I have this exact problem. Everyone else can join the server fine, I can’t. I managed to join once using the ‘open’ command in the console. Since then that doesn’t work. I can join every other server I see on the browser just fine.

    If I try to join through the ‘friends’ or ‘favourites’ tab it sits on the ‘loading please wait’ screen for ages before saying it cannot connect to the host. If I use the server commands it just sits there doing nothing(as far as I can see).



  • We have this problem too, one of our friends cannot join my server while others can.
    We think that the reason is that Chivalry does not install all required software by startup. We came to this solution, because the installer always breaks up in step 1 after pressing the Play buttom in steam. We figuered out that 2 of the 3 parts are C++ and directX, and we think the missing 3. part leads to the joining problem.
    Does someone know which 3 parts should be installed by the steaminstaller, which is actually not working?
    -dice



  • I’m voting that this is a port issue concerning connections from your own network?

    Others can join, because they are on other networks, while those in your LAN can not because they’re trying to join using same port the server is broadcasting from.

    I have open:

    TCP - 7777, 7778 for Chiv, 27030-27039 for Steam.
    UDP - 7777, 7778 for Chiv, 1200, 27000-27015 for Steam.

    In C:\Program Files (x86)\Steam\steamapps\common\chivalry_ded_server\UDKGame\Config \PCServer-UDKEngine.ini, I have

    Port=7777
    PeerPort=7778

    My UDKLogging.exe shortcut contains the following Target: “C:\Program Files (x86)\Steam\steamapps\common\chivalry_ded_server\Binaries\Win32\UDKLogging.exe” AOCFFA-Arena3_P?steamsockets? -seekfreeloadingserver -Port=7777 -QueryPort=27015 -dedicated=true

    Hope something clicks.


Log in to reply