Please help! Game won't launch!



  • Ok so I bought the game, got it installed, and now when I try to open it it starts the update process with 3 steps and then crashes. No error report whatsoever. Please help me out here!

    My computer specs:

    Operating System: Windows 7 Home Premium 64-bit
    System Manufacturer: Hewlett-Packard
    System Model: HP Pavilion dv7 Notebook PC
    BIOS: Default System BIOS
    Processor: Intel® Core™ i7 CPU Q 720 @ 1.60GHz (8 CPUs), ~1.6GHz
    Memory: 8192MB RAM
    DirectX Version: DirectX 11
    DX Setup Parameters: Not found
    User DPI Setting: Using System DPI
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    DxDiag Version: 6.01.7601.17514 32bit Unicode

    Card name: NVIDIA GeForce GT 320M



  • “I don’t know if you tried this or not, but go to C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\RedistChiv and run the two vcredist executables. Then go into DXRedistCutdown and run DXSETUP.exe.”

    http://www.chivalrythegame.com/forums/viewtopic.php?f=69&t=6552&p=54051#p54051

    That should fix it, I had the same issue when I first tried to play.

    Have fun, awesome game!


Log in to reply