Keybinding - arrow keys?



  • Google searches revealed other people are experiencing this problem but other than suggesting that people delete the game folder in My Documents I haven’t seen any workaround for this problem, which is twofold: 1) attempting to bind the arrow keys to movement as primary bindings causes the software to insert duplicate lines of jibberish into the keybinding file and just generally causes a mess of things. 2) Binding the arrow keys for movement as secondary bindings doesn’t cause garbage lines to be inserted, but the bindings don’t work. Specifically, the left and right arrow keys cause you to turn rather than strafe, even though they’re correctly bound to strafe.

    As a loooooong time (since the original Doom) user of arrow keys for movement in games, this is REALLY disappointing. I’ve tried WASD, in other games and this one and it just doesn’t work for me…. meaning right now I’m unable to play this game. Considering just last week I pimped Chivalry to a big group of guys for play at a LAN play we’re hosting this coming weekend with a bunch of consequent purchases, I’m even more disappointed that I’m not going to be able to participate. Is this something that’s eventually going to be resolved?



  • Sorry I’m not familiar with the current issue, but doesn’t hurt to throw a suggestion out. Have you tried manually rebinding them from the UDKInput.ini from you Documents\My Games\Chivalry? Specifically looking at this part:

    Bindings=(Name="A",Command="GBA_AOCLeft",Flag="KBFlag_Movement",FriendlyName="MoveLeft")
    Bindings=(Name="D",Command="GBA_AOCRight",Flag="KBFlag_Movement",FriendlyName="MoveRight")
    Bindings=(Name="W",Command="GBA_AOCMoveForward",Flag="KBFlag_Movement",FriendlyName="MoveForward")
    Bindings=(Name="S",Command="GBA_AOCBackward",Flag="KBFlag_Movement",FriendlyName="MoveBackward")
    

    Would replacing WASD with Up, Down, Left, and Right work?



  • i hadn’t dug into this yet because a friend of mine mentioned it was pretty arcane, but as control schemes go this isn’t too bad. I tried replacing those configs as you mentioned with no effect - bindings still show WASD. There’s another section further down:

    Bindings=(Name="W",Command="MoveForward")
    Bindings=(Name="S",Command="MoveBackward")
    Bindings=(Name="A",Command="StrafeLeft")
    Bindings=(Name="D",Command="StrafeRight")
    

    Gonna try changing that one now.



  • Welp, that’s not working either, but for a lark I reset to defaults, then bound the arrow keys to movement and hit save. The garbage lines were inserted, but then I rebound the garbage lines it inserted for left and right movement to keys that will never be used for anything (I and O) and voila, now I can strafe. Because I can’t delete all the garbage lines I might be in for a lot of fiddling to make all my keys work, but it’s further along than I’ve been.

    Regardless, PLEASE fix this!


Log in to reply