[SOLVED] Cannot see servers as of three days



  • Hello,

    I’ve bought this game about two weeks ago. Everything was fine up until 3 days ago. I’ve been unable to connect to the servers out of no where.

    What happens:
    I hit “Join Game” and nothing ever loads up. I can click on an invisible server and rmb “More information” and then the game crashes.

    I can’t join a friend’s game or accept an invitation.

    I have done the following to solve this:
    1. Restart my computer, reset my router, restart steam.
    2. Re-install game (3 times now)
    3. Disable firewall
    4. Deleted the master server files and other files. Deleted all files from “My Documents/games”. Tried this quite a few times.
    5. Tried joining through the open command.
    6. Upgraded to the steam beta

    I don’t know what else to do. I’ve tried everything suggested here and elsewhere. I love this game and would like to play more of it. Please help me.



  • Hi Jackal,

    Some people have found that opening the server filters in the server browser and setting the game speed to anything but 100% and then setting it back to 100% fixes similar problems. Please try that :)



  • I’ve tried that a few times, and it has not fixed the problem.



  • I’ve re-installed the game a few times since and still nothing has changed. Will there be an official fix for this, since I am not the only one?



  • Okay let’s take a looksee. Please remove the line “Suppress=DevOnline” from the UDKEngine.ini found in Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config.

    Then run the game, sit on the server browser for 10 minutes or so (go get a cup of coffee or something), then exit the game cleanly and attach the Launch.log in a reply here found in Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs.



  • Here is my log. Thank you for the help!



  • Okay you’re not hitting the Master Server…

    Try deleting the Steam\config\MasterServer2.vdf and rerun Steam to make sure that file is clean.

    Then go into Steam and click View from the top menu bar and select Servers. See if it will list servers for the basic Source games (this will tell us if not being able to hit the master server is confined to Chivalry or your computer itself).



  • OK, I’ve done that. Yes, it lists the servers for the basic source games in steam.



  • @Jackal:

    OK, I’ve done that. Yes, it lists the servers for the basic source games in steam.

    Hmm okay, then it is something software-wise that is blocking out Chivalry (not router/modem).

    What kind of firewall/malware/spyware/antivirus software do you use if any?



  • I am using “Avast!”.

    Edit: Well, I figured out the problem. Apparently, McAfee (which I haven’t used in months) decided to start blocking my programs, despite my subscription running out. I noticed this when I ran a quick scan with Avast! that McAfee popped up. I uninstalled McAfee and now I can see the servers in Chivalry.

    Thank you for your help!



  • @Jackal:

    I am using “Avast!”.

    Edit: Well, I figured out the problem. Apparently, McAfee (which I haven’t used in months) decided to start blocking my programs, despite my subscription running out. I noticed this when I ran a quick scan with Avast! that McAfee popped up. I uninstalled McAfee and now I can see the servers in Chivalry.

    Thank you for your help!

    Yarrrrr!!! I have a sneaky suspicion that AV software may be affecting our other friends with server browser problems…

    I’m glad that it’s fixed for you! See you on the battlefield. :k1:


Log in to reply