Game crashes 2-3 times before working fine



  • I added code tags for you to clean it up. I don’t see anything out of the ordinary there…

    Couple of things to try:

    1. Delete the Chivalry directory from Documents\My Games\ (this will reset all video settings and custom keybinds)
    2. Add -windowed to the Chivalry Launch property from Steam
    3. Add -resX=1024 -resY=768 to the Chivalry Launch properties from Steam

    If those don’t work (test each, and remove the launch properties when you’re done), then try launching the game from UDK.exe in C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32. Let’s see if we can get it to crash (UDK.exe has stopped working).



  • Deleting the chivalry dir from \my games works reliably, i’ve done this before. What this does is put the game back in some low resolution in windowed mode and this seems to make it want to start every time. After this i’ve set it to full screen 1920x1080 and then we’re back to the hanging.

    The other ideas seem to do the same thing to me? Start it in windowed mode, this seems to work fine.

    Running UDK.exe directly starts the game fine to main menu, it doesn’t crash.

    So it seems to have something to do with going fullscreen? I’ve got two monitors on my PC, one is a bit older, i’m wondering if that might have something to do with it.



  • Tried disabling my secondary monitor, it doesn’t make a difference.



  • @simonp:

    Tried disabling my secondary monitor, it doesn’t make a difference.

    Hmmmm weird. Let’s try a few more quick ideas.

    Try setting the launch property to:

    -fullscreen -resX=1920 -resY=1080
    

    If that doesn’t help, you can try this for launch properties:

    -windowed -borderless -resX=1920 -resY=1080
    

    ^ That will fake a full screen with a windowed app with no borders. Doesn’t fix the problem, but it’s a workaround.



  • Fullscreen option doesn’t seem to make a difference, game comes up but also hangs like it does without it.

    The -windowed idea brings up the game in windowed mode, non-borderless in 1440x900, so it seems to sort of ignore the options i pass it.



  • @simonp:

    Fullscreen option doesn’t seem to make a difference, game comes up but also hangs like it does without it.

    The -windowed idea brings up the game in windowed mode, non-borderless in 1440x900, so it seems to sort of ignore the options i pass it.

    Woops! My mistake. :x Try this:

    -borderless -resX=1920 -resY=1080
    

    -borderless with the resx and resy without the -windowed is the way to go.



  • Tried, seems to be the same as the -windowed option. It comes up in 1440x990 in a window with a border.



  • @simonp:

    Tried, seems to be the same as the -windowed option. It comes up in 1440x990 in a window with a border.

    Weird! Okay let’s try some last resorts before calling in backup:

    • Remove all launch properties.

    • Delete the Chivalry folder from Documents\My Games (this will reset all video settings and custom keybinds).

    • Verify game cache from Steam.

    Edit:
    I realize that you may have tried some of these before, but just one more time.



  • Yeah i’ve tried verifying/deleting before, did the sequence you posted. Verification was uneventful.

    When i started the game afterwards i got a steam buildbot UAC prompt and it installed directx(first time setup etc.).

    Game then minimized to taskbar and i could not switch to it untill it showed the main menu. Game came up in 1440x990 like before (windowed).

    Changed to 1920x1080 fullscreen true, exit.

    Tried running it, it worked OK 3 times in a row, then hung 2 times, then worked again. So it still seems to be a bit random if it wants to work or not.



  • You said earlier that you were able to run the UDK.exe just fine without it hanging? That went into fullscreen mode and was fine, but launching from Steam into fullscreen mode isn’t fine?



  • Yes, running UDK.exe directly appears to do the exact same thing as running the game through steam/desktop shortcut.
    It either works and goes to main menu or it hangs. I can’t see a difference and i’ve never had it crash - it just hangs in not responding mode.



  • @simonp:

    Yes, running UDK.exe directly appears to do the exact same thing as running the game through steam/desktop shortcut.
    It either works and goes to main menu or it hangs. I can’t see a difference and i’ve never had it crash - it just hangs in not responding mode.

    Okay, thanks. I’ll try directing a dev here if I can catch one (elusive creatures) to offer more assistance.


Log in to reply