Black Screen when joining created Dedicated Server



  • So i created my own dedicated server for my friends to join in . i downloaded it VIA Steam, so here is the command line i used

    UDK.exe AOCFFA-Arena3_P?steamsockets -seekfreeloadingserver -port=27050 -multihome=192.168.1.2 -maxplayers=4

    not sure about what port to enter though, so i just put there 27050. and yes, my ports are open.

    now, when joining the server, it loads as if its joining then suddenly This

    i dont know whats wrong . also, i am not experienced at doing this.

    thanks for the help in advance



  • Hi hawkerrose,

    Which UDK.exe are you using? What is the location of it?

    Do you normally get graphical anomalies like that when you launch the game through Steam and join an existing server from the server browser?



  • No, i dont have any problems with the game what so ever. i only get that when i try to join the server i created . i am using the Steam version
    (C:\Program Files (x86)\Steam\steamapps\common\chivalry_ded_server\Binaries\Win32\UDK.exe)



  • Okay, to make sure that I understand correctly, you made a shortcut to the UDK.exe that you specified above and added the launch options that you listed in the Original Post. You launch this shortcut to start the dedicated server. Then you launch the game normally through Steam (to try to connect to the dedicated server hosted on the same computer) and you get the screenshot that you posted in the original post.

    Does that sound right?



  • yes, that is correct . oh and also, i tried it to the UDKGame.exe but both gave the same result.



  • Okay! I’m not as versed with the server, so let’s do some exploring.

    Does it still happen if you remove the -multihome property?

    If yes, try UDKLogging.exe for the server instead of UDK.exe with the same launch properties.



  • and its still giving the same result with the UDKLogging.exe … i tried both with and without the -multihome property


  • Developer

    Post the log from your client as well as from the server (run with UDKLogging; UDK.exe won’t write to a log file).

    Note that if they’re trying to join by your IP address, they’re probably going to need to include the port. If your IP was 1.2.3.4, they’d join with
    open 1.2.3.4:27050

    and if you’re playing on the same machine that’s hosting it, you’d open 127.0.0.1:27050


Log in to reply