[SOLVED] Chivalry will not launch



  • I try to launch the game, and it does not open, I receive an error message saying: Failed to launch (unknown error).
    I am using Windows 7, with specs that far exceed the minimum required for the game, and I have all the latest drivers, so those aren’t the problem. I took a snip of the error message and I have it attached here. I also have the dxdiag.txt there.
    I’ve now attached the only log that the forum will let me attach.



  • Could REALLY use some help here. Anyone?



  • It’s Christmas, relax.

    Try verifying the game cache.



  • @ReMixx:

    It’s Christmas, relax.

    Try verifying the game cache.

    Already done that, actually. Many times.



  • Now that I’ve seen a screenshot of it… I thought the unknown error would be a small windows box with a red sign on it. That looks like a Steam error. With that in mind, I was able to find similar cases of “unknown error”, but with other games.

    http://steamcommunity.com/discussions/f … 129657245/



  • What happens if you launch Chivalry directly from it’s UDK.exe located here: C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32 ?



  • @ReMixx:

    What happens if you launch Chivalry directly from it’s UDK.exe located here: C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32 ?

    This happens:



  • @Gwain96:

    @ReMixx:

    What happens if you launch Chivalry directly from it’s UDK.exe located here: C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32 ?

    This happens:

    Interesting…

    Have you tried completely reinstalling (including redownloading from Steam) it yet?



  • @GhoXen:

    Now that I’ve seen a screenshot of it… I thought the unknown error would be a small windows box with a red sign on it. That looks like a Steam error. With that in mind, I was able to find similar cases of “unknown error”, but with other games.

    http://steamcommunity.com/discussions/f … 129657245/

    No solution there worked.



  • @ReMixx:

    @Gwain96:

    @ReMixx:

    What happens if you launch Chivalry directly from it’s UDK.exe located here: C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32 ?

    This happens:

    Interesting…

    Have you tried completely reinstalling (including redownloading from Steam) it yet?

    I deleted everything in the /common/chivalrymedievalwarfare folder and verified the game cache, but I haven’t tried that.



  • @Gwain96:

    I deleted everything in the /common/chivalrymedievalwarfare folder and verified the game cache, but I haven’t tried that.

    Please try uninstalling the game - control panel -> uninstall programs and features and then redownloading it. Steam downloads games to a temp folder before unpacking/moving over into the common/ directory. It may have had a corrupted download or some freak error when moving into the common/ directory that cache verification is failing to pick up on (like folder permissions/read-only, etc.).



  • @ReMixx:

    @Gwain96:

    I deleted everything in the /common/chivalrymedievalwarfare folder and verified the game cache, but I haven’t tried that.

    Please try uninstalling the game - control panel -> uninstall programs and features and then redownloading it. Steam downloads games to a temp folder before unpacking/moving over into the common/ directory. It may have had a corrupted download or some freak error when moving into the common/ directory that cache verification is failing to pick up on (like folder permissions/read-only, etc.).

    No difference. Same error.



  • @Gwain96:

    @ReMixx:

    @Gwain96:

    I deleted everything in the /common/chivalrymedievalwarfare folder and verified the game cache, but I haven’t tried that.

    Please try uninstalling the game - control panel -> uninstall programs and features and then redownloading it. Steam downloads games to a temp folder before unpacking/moving over into the common/ directory. It may have had a corrupted download or some freak error when moving into the common/ directory that cache verification is failing to pick up on (like folder permissions/read-only, etc.).

    No difference. Same error.

    Is the UDK.exe marked as read-only? (Mine is NOT)

    When you right click the UDK.exe and select properties and click the security tab, is your Windows username listed as having full permissions to run it?

    What happens if you try to run it as administrator?



  • @ReMixx:

    Is the UDK.exe marked as read-only? (Mine is NOT)

    When you right click the UDK.exe and select properties and click the security tab, is your Windows username listed as having full permissions to run it?

    What happens if you try to run it as administrator?

    No
    Yes
    Same thing as if I double-click.



  • @Gwain96:

    @ReMixx:

    Is the UDK.exe marked as read-only? (Mine is NOT)

    When you right click the UDK.exe and select properties and click the security tab, is your Windows username listed as having full permissions to run it?

    What happens if you try to run it as administrator?

    No
    Yes
    Same thing as if I double-click.

    Interesting, okay. One last thing that I want to try before passing it along to the higher-ups.

    Right click Chivalry in your Steam Game Library and select Properties. From there select the Set Launch Options. Add this to that:

    -windowed -1024 -768
    

    Then try to launch it through your Steam Game Library.



  • @ReMixx:

    Interesting, okay. One last thing that I want to try before passing it along to the higher-ups.

    Right click Chivalry in your Steam Game Library and select Properties. From there select the Set Launch Options. Add this to that:

    -windowed -1024 -768
    

    Then try to launch it through your Steam Game Library.

    Nope. No change.



  • @Gwain96:

    Nope. No change.

    Boo! Okay, I’ll pass it along to the devs. Please keep in mind that it is the holidays so they will be delayed in responding.



  • @ReMixx:

    @Gwain96:

    Nope. No change.

    Boo! Okay, I’ll pass it along to the devs. Please keep in mind that it is the holidays so they will be delayed in responding.

    Awesome, thanks.
    Oh! and one more thing! This only worked once, mind you, but I opened the UDKGame.exe twice at some point, (the first time /i opened it, nothing happened) and Chivalry seemed to be starting up, but there were two things open. I tried to close one, but it closed both of them. Not sure if that helps, but it’s certainly a thing.



  • Any .dmp files in Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs?



  • @ReMixx:

    Any .dmp files in Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs?

    No. just 3 text documents: Launch, Launch_2, and Launch-Backup-2012.12.24-23.52.20
    EDIT: Actually, that’s in the UDKGame under /steamapps/common/chivalrymedievalwarfare. I deleted the one in /my games because it was one of the suggested solutions I came across (that didn’t work)


Log in to reply