Your video card does not support alpha blending…



  • Hello! A few days ago I purchased this game during the steam sale and was able to play it perfectly. Recently though, I got a new video card, an AMD 7870 (before I had a GTX 460) and since then have constantly been receiving the message:

    Your video card does not support alpha blending with floating point render targets(D3DFMT_A16B16G16R16F), which is required to run this game. Exiting…

    Now when I got the new card I installed the drivers from the website linked to by the CD and then uninstalled the old Nvidia drivers through the uninstall feature on the control panel. I don’t know much about computers and greatly appreciate any help you guys can give me.



  • That’s a new one. When does the message happen? As soon as you launch the game?

    Does it happen to any other games?

    Try running the DXSETUP.exe again from C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\RedistChiv\DXRedistCutdown.

    If that doesn’t work, try deleting the Chivalry folder from Documents\My Games.

    If that doesn’t work, try reinstalling Chivalry.



  • It happens right when I click on the game in steam, and I have attempted the DXSETUP thing. I’m going to go try to reinstall it right now, I’ll get back to you on the success with that.



  • Well, I just reinstalled it and am having the same problem.



  • Just to check (going for captian obvious of the year): did you restart your computer after installing the new drivers?



  • Yes I did, but do you know if by chance installing the new driver before removing the old one might be one of the issues?

    EDIT: I also seem to be having a new problem with killing floor, receiving the error:

    “Please enable Direct3D acceleration. You can do this by starting dxdiag and enabling Direct3D acceleration in the Display1/2 tab after installing DirectX 8.1b (or later) and the latest drivers for your graphics card.”



  • I’m not sure, but it couldn’t hurt re-installing the latest drivers for your graphics card. no idea on killing floor though.



  • ok ill try that, thanks anyway.

    EDIT: That seemed to have worked, which means I am a moron and screwed up at some point when installing the drivers. Thanks for the help everyone!



  • @Khenir:

    I’m not sure, but it couldn’t hurt re-installing the latest drivers for your graphics card. no idea on killing floor though.

    Good catch 8-)

    @Anoi:

    ok ill try that, thanks anyway.

    EDIT: That seemed to have worked, which means I am a moron and screwed up at some point when installing the drivers. Thanks for the help everyone!

    LOL! You’re not a moron. It happens to all of us at some point. Glad that it works for you! See you on the battlefield. :k1:


Log in to reply