Another "Crash on launch" thread.



  • I got this game back in october and played it for a bit then as well as early november, but after uninstalling it and reinstalling it a day ago, it no longer seems to want to start, giving an unknown software error crash sometimes right after the splash screen and before a game window opens, sometimes immediately as the game window opens and the company logo shows up.

    I’ve tried reinstalling the game and verifying the game cache and deleting the My documents folder, and have updated my video drivers.



  • I’ve now also tried to run the two vcredist executable files in C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\RedistChiv and DXSETUP.exe in DXRedistCutdown, which did nothing.

    Anything else?



  • Well, this is weird, but after backing up and reinstalling my game off my SSD and onto my backup harddrive, the game now works!

    So I guess there’s some sort of an issue with the game and SSDs?


Log in to reply