Game disconnects me but doesn't kick me, constantly



  • Every time I join a populated server I play for about 30 seconds and then I DC, but it doesn’t kick me from the server. so I have to manually leave the game and rejoin, but the exact same thing keeps happening, everyone in the game just starts walking forward or freezes (depending on what action they were doing before I DC). it doesn’t happen on every server but the same ones keep ending in the same result at the same time. it use to last for about 2-5 seconds and then I wouldn’t have it happen again on that server.

    Is anyone else experiencing this or something similar?
    Feel free to leave Questions or suggestions…



  • the same thing happens to me with the difference that it happens on EVERY server. I just bought the game and i can’t play :(
    it freezes after 10-20 sec and if i wait for like 30 sec it finally disconnects me.
    please if someone has ANY idea how to solve this problem, i will love you forever.

    PS. not the first game this happens, but i play a lot of games and it happens in only 2-3 games



  • Seriously is there noone who can help us?
    At least if there is no way to fix that it would be fair to get a refund. The game is completely unplayable and it’s not something i could know prior to buying it.



  • Try opening the in-game console (tilde key) and typing in:

    reconnect
    

    right after it disconnects you. Many have reported this workaround successful for them in similar situations.



  • ok i’ll try that
    just an update today i could play at the Greek server (i live in Greece)
    i didn’t try other servers



  • @ReMixx:

    Try opening the in-game console (tilde key) and typing in:

    reconnect
    

    right after it disconnects you. Many have reported this workaround successful for them in similar situations.

    thx for that, it actually worked
    unfortunately it bugs the sound and then i have no sound



  • See here:

    FIX - Disconnect from Server 5-10 seconds after Joining
    viewtopic.php?f=69&t=7886


Log in to reply