New "fix" for UDK.EXE stopped working … PLEASE READ DEVS!



  • Hey guys, so i spent a lot of last night trying to troubleshoot my problem with UDK.exe has stopped working. I tried all of the solutions, the main ones that worked being to delete the entire config folder, re-verify files and start the game up again. The problem with this “fix” is that whenever i played for about 15-20 minutes sometimes it would go longer, it would eventually crash. I played around with this a bit and originally i thought it was the resolution setting or changing to fullscreen setting. If i left the default settings which are windowed mode and a 1440xsomething resolution (for some reason) everything seems to stay normal and i can play and restart the game etc. But who wants to play on 1440x whatever res, and in windowed mode? not me, that’s who! So this is obviously not a solution: to delete the whole folder each time i want to play only to have it work for about 20 min average.

    I found something interesting in my event viewer that i haven’t seen mentioned before which boggles me. But heres the log:

    Faulting application name: UDK.exe, version: 1.0.10246.0, time stamp: 0x50bd4c27
    Faulting module name: xfire_toucan_45941.dll, version: 1.0.0.45941, time stamp: 0x50c25b23
    Exception code: 0xc0000005
    Fault offset: 0x00006258
    Faulting process id: 0x16f4
    Faulting application start time: 0x01cde43e19687837
    Faulting application path: G:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe
    Faulting module path: C:\Program Files (x86)\Xfire\xfire_toucan_45941.dll
    Report Id: 7c525e91-5032-11e2-b500-3085a93dd23c

    As you can see, it’s a problem with XFIRE! my god so i turn off xfire. EVERYTHING WORKS! Then i turn it back on, crashes again. So this time i just turned off the xfire in-game feature for chivalry only and it works! I re-installed xfire, to see if it’s corrupted, and enabled in-game and it still crashed. Soo, def seems to be an issue with x-fire’s in-game feature.

    I’m just posting this as it is a “temporary fix/workaround” and not a true fix, because i don’t know whether xfire needs a patch or chivalry does… but i hope the devs see this as anyone that uses x-fire is likely experiencing this, and they think its something with directx, their video card, some config settings… where all the while its x-fire.

    Anyway, i hope this helps, and also hope it gets added to the known fix/workaround thread, even if only to help temporarily.

    Thanks for reading!

    PS: My Specs

    Asus P77 V Pro Mobo
    Intel 3770K @ 4.6
    GTX 680
    8GB 2600 GSKILL RAM
    120GB SSD Vertex 3 or 4 (forget)


Log in to reply