Your framerate sucks Megathread 1.0



  • So as a person who played the shit out of past Unreal games, I’ve become pretty adept at reading and interpeting the .ini files and whatnot. I decided that since there is no central resource for Chivalry framerate improvement information that there should be one and that I was stupid and drunk enough to get it did.

    If anyone makes a post in this thread that doesn’t suck and is useful in general for framerate shit, I’ll edit this post and include a quote of your post on the bottom. That way the poor kids who come to this thread looking for help won’t have to crawl through every page looking for answers to their shitty problems.

    First of all, how on Earth do I check what my fps is? Do I have to use something like fraps or whatever?

    • Hell no, you don’t have to at all. Every Unreal Engine game (this one included) has a common command called “stat fps” that you can put into the console, which is the thing that lets you type stuff when you press the ~ button on your keyboard at any point while in the game. If you want to turn it off, just type it in there again. It’s like a toggled command.

    • If you want to use Fraps instead for whatever reason, go ahead I guess. I’m not a cop.

    There are a lot of .ini files in the Chivalry sections of my hard drive… which one does the game actually give a shit about for fixing framerates?

    • This forum doesn’t support indented paragraphs.

    • My Documents > My Games > Chivlary Medival Warfare > UDKGame > Config > UDKSystemSettings.ini

    • Make a backup of the file (e.g. copy paste another one into the same folder (or wherever you can remember you put it later) but make sure the name is changed a bit) before you fuck with it.

    • If you were too stupid to listen to what was said in the previous bullet point, then if shit goes bad (like the game won’t start for whatever reason), then just delete the above file and start the game again. The game, on startup, will replace the file with standard and default shit.

    Okay… so what do I do with this file you just mentioned?

    • The part at the top of it says [SystemSettings]. Each section of the .ini files have titles like this. The section at the top, under the aforementioned title, is the only relevant one that you will care to use when trying to make your game work better (unless for some reason you’re playing on a mobile phone rather than a potato).

    • As such, every edit you make should only be confined to the [SystemSettings] stuff in the beginning of the file. Editing any of the stuff further down the line would just be a waste of your time.

    • Anyway, just changing fields from False to True are good enough to make editions to the game. Many of which will affect either your framerate of the visual quality of the stuff in the game.

    • As for figuring out what each of the fields mean, there are useful resources that already exist on the internet (as you’d expect, of course). Probably the most useful and simple explanation of the majority of the fields in the UDKSystemSettings.ini file come to us from the Tribes: Ascend (which is built from the same engine as Chivlary here) community’s explanation of their .ini files.

    • In fact, you can copy paste a lot of the stuff from Tribes: Ascend fps configs (there’s a lot of them), use them here, and get away with it for the most part.

    Help, I’m trying to play this game on a potato! What do?

    • Obviously you don’t care about how the game looks - you just want to play it and have it be as fast as possible. Here’s what you do.

    • Just for the sake of trying to be directly helpful, here’s what I have in my UDKSystemSettings.ini file at the moment because, like you, I also play this game on a potato:

      ! ! [SystemSettings] ! StaticDecals=True ! DynamicDecals=False ! UnbatchedDecals=True ! DecalCullDistanceScale=0.100000 ! DynamicLights=False ! ;above dropped framerate from ~50 avg to ~15 avg when set to True ! DynamicShadows=False ! LightEnvironmentShadows=False ! CompositeDynamicLights=False ! ;above seems not to affect framerate or made any noticeable visual changes ! SHSecondaryLighting=False ! ;above seems not to have affected framerate or made any noticeable visual changes ! DirectionalLightmaps=False ! ;^^^^above, when set to False, makes all textures appear black. when set to true, reduces framerate from ~50 avg to ~30 avg ! MotionBlur=False ! MotionBlurPause=False ! MotionBlurSkinning=1 ! DepthOfField=False ! AmbientOcclusion=False ! Bloom=False ! bAllowLightShafts=True ! ;above seems not to have affected framerate, but has made no noticeable change when set to True ! Distortion=False ! FilteredDistortion=False ! DropParticleDistortion=True ! bAllowDownsampledTranslucency=False ! SpeedTreeLeaves=False ! SpeedTreeFronds=False ! OnlyStreamInTextures=True ! ;above, when set to True, appears to increase avg fps by at least 10 ! LensFlares=False ! FogVolumes=False ! FloatingPointRenderTargets=False ! OneFrameThreadLag=False ! UseVsync=True ! UpscaleScreenPercentage=False ! Fullscreen=False ! Borderless=True ! AllowOpenGL=False ! ;AllowOpenGL, if set to True, seems to crash the game on startup ! AllowRadialBlur=False ! AllowSubsurfaceScattering=False ! AllowImageReflections=False ! AllowImageReflectionShadowing=False ! bAllowSeparateTranslucency=False ! bAllowPostprocessMLAA=False ! bAllowHighQualityMaterials=True ! MaxFilterBlurSampleCount=0 ! SkeletalMeshLODBias=4 ! ParticleLODBias=10 ! FoliageLODBias=10 ! SSAOQuality=0 ! DetailMode=0 ! MaxDrawDistanceScale=1.200000 ! ShadowFilterQualityBias=-1 ! MaxAnisotropy=0 ! MaxMultiSamples=1 ! bAllowD3D9MSAA=False ! bAllowTemporalAA=False ! TemporalAA_MinDepth=500.000000 ! TemporalAA_StartDepthVelocityScale=100.000000 ! MinShadowResolution=0 ! MinPreShadowResolution=8 ! MaxShadowResolution=0 ! MobileShadowTextureResolution=0 ! MaxWholeSceneDominantShadowResolution=0 ! ShadowFadeResolution=0 ! PreShadowFadeResolution=8 ! ShadowFadeExponent=0.100000 ! ResX=800 ! ;The above line will change the width of the resolution for the game (fullscreen and not). ! ;If you want a custom resolution, here's where you input it. ! ResY=600 ! ;Same thing as mentioned for ResX above, but it's obviously the height instead of the width. ! ScreenPercentage=85.000000 ! ;Above, if you want to have a big window with the actual displayed portion of the window shrunk, here's where you do it. ! SceneCaptureStreamingMultiplier=0.000000 ! ;No idea what this does. Set it to zero. ! ShadowTexelsPerPixel=1.000000 ! PreShadowResolutionFactor=0.000000 ! bEnableBranchingPCFShadows=False ! bAllowHardwareShadowFiltering=False ! TessellationAdaptivePixelsPerTriangle=48.000000 ! bEnableForegroundShadowsOnWorld=False ! bEnableForegroundSelfShadowing=False ! bAllowWholeSceneDominantShadows=False ! bUseConservativeShadowBounds=False ! ShadowFilterRadius=0.000000 ! ShadowDepthBias=0.012000 ! PerObjectShadowTransition=60.000000 ! PerSceneShadowTransition=600.000000 ! CSMSplitPenumbraScale=0.500000 ! CSMSplitSoftTransitionDistanceScale=4.000000 ! CSMSplitDepthBiasScale=0.500000 ! CSMMinimumFOV=90.000000 ! CSMFOVRoundFactor=4.000000 ! UnbuiltWholeSceneDynamicShadowRadius=1000.000000 ! UnbuiltNumWholeSceneDynamicShadowCascades=0 ! WholeSceneShadowUnbuiltInteractionThreshold=50 ! bAllowFracturedDamage=False ! NumFracturedPartsScale=1.000000 ! FractureDirectSpawnChanceScale=1.000000 ! FractureRadialSpawnChanceScale=1.000000 ! FractureCullDistanceScale=2.000000 ! bForceCPUAccessToGPUSkinVerts=false ! bDisableSkeletalInstanceWeights=false ! HighPrecisionGBuffers=False ! AllowSecondaryDisplays=False ! SecondaryDisplayMaximumWidth=1280 ! SecondaryDisplayMaximumHeight=720 ! ;;;;;;;;;;;;;;;;IRRELEVANT SECTION BELOW;;;;;;;;;;;;;;;; ! MobileFeatureLevel=0 ! ;... ! ;... ! ;... ! !

    • Obviously, the code pasted above is only useful if you replace the beginning part of the [SystemSettings] section in your .ini file (see above for the file path - it’s italicized and underlined). Don’t just blindly copy that shit into your .ini file - the ending part of it needs to be chopped off so that it fits in properly. I added that so that you knew exactly how much of the file you need to replace.

    Why are there a bunch of ; things in that above code snippet you shared with me?

    • It’s the comment character for .ini files. When you begin a new line (and ONLY when you begin a new line) in any .ini file with the ; symbol, the game or whatever is using the .ini file will just ignore that line and there won’t be any crazy errors and shit that pop up because of the stuff you write after it on that line (and only that line). So yeah.

    Help! I’m too stupid to read and just blindly copy-pasted the above code snippet into my .ini file and now the game doesn’t work! sadface.jpg

    • Get rid of the ending periods and whatnot

    • After that, go practice reading comprehension with the other middle school children in your local community.

    So I got that thing you copy-pasted to work and the game looks like shit! You’re a _______!

    • Stop playing the game on a potato and get a better computer. Right after you get a job.

    Help! The game crashes on startup because I did fucked around and screwed up the game!

    • There are three likely possibilities for why this happened:

      • You inadvertently changed AllowOpenGL to True. Change it back to False and you should be fine.

      • You for whatever reason changed PerformedBucketing to False. Change it back to True and you should be fine.

      • You apparently changed a number setting to something that doesn’t make any sense to the game. Look for anything obvious in your .ini file and then if you give up looking for shit… just delete the file and when you restart the game it’ll automatically regenerate a new file to replace it that works with the default settings again. Hope you made a backup like I said near the top of the post! qq

    For some reason I have some shitty mouse lag in this game. How do I fix that?

    • In the .ini file that this thread centers around (see the first question in the thread in case you forgot or somehow missed it), change the OneFrameThreadLag section from True to False. I have no idea why anyone would want this to be set to True by default. Perhaps because for people with high framerates, that one frame is an insignificant amount of time… but for us potato-computer users, that one frame is very noticeable and quickly becomes a pain in the ass.

    • You’re welcome.

    My computer/laptop/potato is trying to run the game using some shitty thing rather than the graphics card like I want it to. How fix?
    @badastronaut7:

    I was having an issue that I posted in this thread I believe. I’m running the game on a rather expensive and powerful laptop, but instead of running on my nvidia 670m, It was running on my shitty integrated graphics card. If anyone else is having a similar problem, go to your graphics card options, and if they give you the option to select individual programs to run with which card, find UDK.exe, and change it to the right graphics card.
    Hope this helps someone!

    All of your recommendations are complete shit and you’re a terrible person for making this fucking megashit thread post.

    K. Here’s some other losers’ ideas:
    @Lann094:

    I’ll just leave my SLI settings here, for anyone that wants to try forcing SLI Support.


    Firstly you need to add UDK.exe from ‘\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32’ then just change the options that are in bold. It feels like I get an fps boost with these settings, but it might be different for other rigs.

    @Retsnom:

    Minus the speed hacking scandal that I am currently defending against. I too have been looking for tweaks to make this game run at a decent level. I first found this console command and posted information here: viewtopic.php?f=69&t=5235

    The console command is: scale lowend And there is more information in the above link.

    I also posted the INI changes I made to the system, game and engine ini files and can be found here: viewtopic.php?f=69&t=9007

    Feel free to try them out. Again back up any and all default files you are testing. Go back to default if you are either having problems. Be sure to read all the instructions in the first link above as you may have to go back and change menu settings.

    INI shit scares me and I just pissed myself after having had to read this post. Can I do something else to help my framerate?
    @Pvt.Bloody:

    I noticed that on my Intel Wolfdale e8200 (overclocked to 3.2 GHz), setting the priority of UDK.exe (from Task Manager) to High, gave a visible boost to FPS.
    The game is very CPU dependable. MSI afterburner reports that my GTX 260 is used around 40%.



  • These hints are quite useful, it does increase fps really well on potato style computers. The only thing that annoys me about this config is how it limits view range. It’s hard to play archer class hehe.

    Anyway, do you know which settings are for this fog and view range? Because on your cfg view range is pretty limited and I don’t know what causes that. :(



  • First impression: MaxDrawDistanceScale=1.200000 needs to be increased. I could be wrong, though.

    Even if it isn’t that, though - whatever it is, it will be some field in that .cfg excerpt above.



  • OneFrameThreadLag=False will just make your FPS even worse if your game is struggling to maintain smooth FPS already. That one frame is a buffer so that your system is rendering things smoother.

    The only reason to use that is if your PC is basically running this game flawlessly without any FPS drops.

    I say this cuz I spent 3 days tweaking this game, wondering why it ran like complete POOP and then remembered I had set that to False.

    The only thing that really seems to affect my fps is dynamic lighting, maybe particle quality and the SSAO/ambient occlusion stuff I believe. Doesn’t seem to make much different with the rest of it, but I’m on a 4 core 3.8ghz radeon 6970 and honestly this game should run even better than it is for me. It only uses 2 cores, that’s the real issue. Maybe by 2020 games will actually utilize modern CPUs.



  • I’ll just leave my SLI settings here, for anyone that wants to try forcing SLI Support.


    Firstly you need to add UDK.exe from ‘\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32’ then just change the options that are in bold. It feels like I get an fps boost with these settings, but it might be different for other rigs.



  • i sometimes get this issue it must be something with the game as i just did a fresh install of windows and i still get it but very rarly i just turn game off for 5 then go again



  • Thank you for your work, it really helps. I’d love to know which commands are responsible for “making terrain black” and strength of this “view distance fog”, because im trying to experiment with my performance now, but I can’t find proper lines



  • @Chromek:

    Thank you for your work, it really helps. I’d love to know which commands are responsible for “making terrain black” and strength of this “view distance fog”, because im trying to experiment with my performance now, but I can’t find proper lines

    Was it that way before applying his suggestions?



  • I just deleted all my config files to create fresh ones, then implemented your cfg and most of the terrain is black. Dunno why, maybe thats something on my side, but on fresh configs everything is fine (except kinda low fps).



  • @Chromek:

    I just deleted all my config files to create fresh ones, then implemented your cfg and most of the terrain is black. Dunno why, maybe thats something on my side, but on fresh configs everything is fine (except kinda low fps).

    DirectionalLightmaps=False

    Set this from False to True and the maps shouldn’t be black anymore.



  • When i play on a server with more then 10 ppl my framerate goes down the drain. Is this a problem with my ram?



  • @Fernando:

    When i play on a server with more then 10 ppl my framerate goes down the drain. Is this a problem with my ram?

    Most likely CPU. This game is very CPU intensive and it only gets more intensive as more players are on the server.



  • So that means even tho my system meets the recommended system requirements, it still lags… Even tho its a great game that makes me an unhappy customer >_<



  • Thanks, but even your potato config couldn’t help me.



  • Minus the speed hacking scandal that I am currently defending against. I too have been looking for tweaks to make this game run at a decent level. I first found this console command and posted information here: viewtopic.php?f=69&t=5235

    The console command is: scale lowend And there is more information in the above link.

    I also posted the INI changes I made to the system, game and engine ini files and can be found here: viewtopic.php?f=69&t=9007

    Feel free to try them out. Again back up any and all default files you are testing. Go back to default if you are either having problems. Be sure to read all the instructions in the first link above as you may have to go back and change menu settings.



  • I love this entire post! It made me giggle, though I’m not sure why I was reading it. Probably looking for .ini hints, though .inis are usually pretty readable to me.

    Oh, right, because even on my beast of my machine I get random slowdown sometimes, usually on Moor, and it seems to have to do with the lighting effects. Someone in Interitus told me how to disable that annoying blinding sunlight that comes from over the lake and it seems to have mitigated the issue, though everything looks pretty drab now =[

    Anyone else had random slowdowns rather than constant FPS losses?



  • I noticed that on my Intel Wolfdale e8200 (overclocked to 3.2 GHz), setting the priority of UDK.exe (from Task Manager) to High, gave a visible boost to FPS.
    The game is very CPU dependable. MSI afterburner reports that my GTX 260 is used around 40%.



  • I just wanted to add that one frame thread lag reduces stutter, almost doubles fps and is used (by default) in almost every game released today. RO2 had an option for it but later removed the option and just left it in by default.



  • @Peregrine7:

    I just wanted to add that one frame thread lag reduces stutter, almost doubles fps and is used (by default) in almost every game released today. RO2 had an option for it but later removed the option and just left it in by default.

    do you know the cvar config setting or was this an option in those game’s menus? If you can find us an example of the cvar it maybe possible to find it within the game engine for testing.



  • Also, does anyone know how to get rid of that weird stutter? I made a post about it here: http://www.reddit.com/r/ChivalryGame/co … _every_30/

    I just heard it may only be on duel servers.


Log in to reply