[SOLVED] Infinite turning around



  • My player constantly turns around…I can attack, defend and move but my player keeps turning (left-up). I tried to unplug mouse, gamepad and keyboard but nothing changed. All other games haven’t this problem.

    PS: I just bought the game, so I’ve never played it “normally”



  • up



  • Remove any gamepads or controllers that you have plugged in.



  • […] I tried to unplug mouse, gamepad and keyboard but nothing changed



  • @Arkas000:

    […] I tried to unplug mouse, gamepad and keyboard but nothing changed

    So if you start the game without the gamepad plugged in (as opposed to unplugging it while the game is already running), it still does it?



  • exactly



  • What kind of mouse and keyboard do you have? Are they fancy high-end peripherals that have their own special software for them? People have had issues in the past with the Razer Synapse software for example.



  • Razer Lachesis and Logitech Illuminated keyboard.
    The razer hasn’t it’s software installed…
    The only software installed is Logitech SetPoint for the keyboard. I tried to close it but nothing is changed.



  • Do you happen to have any basic cheapo mouse and keyboard laying around that you could try? Just to rule out (or in?) the nice high end gear.



  • I “stole” the mouse to my roommate (a 5$ ugly value mouse) to try but the problem is still here



  • @Arkas000:

    I “stole” the mouse to my roommate (a 5$ ugly value mouse) to try but the problem is still here

    Does he have a value keyboard that you can “steal” too? Well I’m running out of ideas… the last resort is to delete the Chivalry folder from Documents\My Games. This will reset all video settings and custom keybinds.



  • @ReMixx:

    Does he have a value keyboard that you can “steal” too? Well I’m running out of ideas… the last resort is to delete the Chivalry folder from Documents\My Games. This will reset all video settings and custom keybinds.

    I solved with a very strange method: I put into the Binaries\Win32 folder the Xinput and DirectInput libraries.
    http://msdn.microsoft.com/en-us/library/windows/desktop/ee417014(v=vs.85).aspx
    I don’t know why but now the game is perfect.
    I decided to try these libraries because I have always obtained strange results with them.
    Thank you very much for your support ReMixx



  • @Arkas000:

    @ReMixx:

    Does he have a value keyboard that you can “steal” too? Well I’m running out of ideas… the last resort is to delete the Chivalry folder from Documents\My Games. This will reset all video settings and custom keybinds.

    I solved with a very strange method: I put into the Binaries\Win32 folder the Xinput and DirectInput libraries.
    http://msdn.microsoft.com/en-us/library/windows/desktop/ee417014(v=vs.85).aspx
    I don’t know why but now the game is perfect.
    I decided to try these libraries because I have always obtained strange results with them.
    Thank you very much for your support ReMixx

    Huh! That is weird. Glad that you solved it and thanks for sharing with us :)


Log in to reply