[SOLVED] Something is wrong with my game



  • Hello people,

    since today I’ve an awkward error everytime I launch the game.

    In the first place, I don’t see any servers anymore. Then, if I want to join a friend over steam I’ll get the error that I lost the connection to the host. Nevertheless I wanted to play the game, so I played some offline against bots and I noticed that I didn’t have my veterans helmets anymore, but the kickstarter helmets although I wasn’t participating at the kickstarter project.

    My question is, if this bug is already known and if there is a fix?
    I reinstalled the game and tried to validate the files, which showed me 1 error which was fixed. After I re-launched this winbot_builder appeared for the first launch installer (or somehting, I didn’t pay much attention to the name).

    Thanks in advance,

    Wintersun



  • Joining friends through steam is not working properly, you can try to go the friend steam profile page and click “join game” from there, it will open another window with servers IP and port (xxx.xxx.xxx.xxx:xxxx, example: 198.133.215.14:9880), copy it and the open in-game console by pressing “~” and type "open xxx.xxx.xxx.xxx:xxxx (where x are the IP address you copied) then press enter. That way you should be able to join your friend.

    I dont know why your progress with weapons was reset, but sometimes offline mode shows it wrong (if settings files were corrupted or something), try to join a server of your friend to see if it does and shows your unlocks properly.



  • Oh, I’ll try that out. But no friend is playing this game at the moment so I’ll have to wait.

    And I forgot to mentions that my weapon unlocks are NOT corrupted, only my unlocked veteran helmets.

    Thank you :)

    **
    EDIT: I tried your way to join him with the IP in the console, I got the error that my connection to the host has been lost… :S**



  • @Wintersun:

    **
    EDIT: I tried your way to join him with the IP in the console, I got the error that my connection to the host has been lost… :S**

    What exactly occurs before you lose connection? Do you just get booted off instantly, or does the game kind of hang, with players walking in a straight line and nothing happening, then getting booted?



  • I can’t even get inside a game. I don’t see any servers in the browsers, nor can I join over steam or ip. If I try to join over the ip or steam I’ll get the error “Lost connection to the host” .

    Only host game works, but there I have the problem that I have the kickstarter helmets, which I shouldnt have.



  • Are you by any chance opted into the beta? Check by going to your library in steam, then right click on Chivalry and click properties. Click on the Betas tab and if you ARE opted in, it will say Beta Chivalry Beta. To opt out, click on NONE - Opt out of all beta programs. Then there will be a 1 gb download to occur to get you back to the normal game.

    That’s the only thing I can think of as to why you are having problems AND you can’t join any of your friends either or other servers.

    Let me know.



  • No, I am not participating at the beta. Still doesn’t work.



  • Delete the Chivalry folder from Documents\My Games if you haven’t done so recently.

    Also try rebooting your modem. Sometimes that can help.



  • Yesterday , when I launched the game it just worked again. I didn’t do anything , it just fixed itself :s
    I can join every server again and I have my helmets back.

    Thank you guys anyways for your advices.


Log in to reply