Black screen on startup

  • When I try to run chivalry, the Torn Banner studios logo pops up, and then it launches the game window. Then, the windows icon for loading (The light blue spinning circle) appears in the middle of the screen for roughly half a minute, and then nothing happens. The screen stays black, no audio is played, and pressing buttons yields no results. Upon CTRL-ALT-DELETEing out of fullscreen, I found out that the program shows up as (Not Responding) in the task manager. I ended the process, tried running it 4 more times, and was unsuccessful with each attempt. I verified the integrity of the cache via steam, Uninstalled and reinstalled the game, and nothing seems to work. I have played the game before, on this computer, less than a week ago. I dont know why it’s acting up now. Attached is the launchlog, I read on similar posts that this is helpful to finding the problem.

    EDIT: DxDiag.txt also attached.

  • I think this may be your system specs, specifically your graphics card…

    From a quick google:

    Even the laptop version of the 8800M is ranked far above the Intel HD 3000

    Chivalry Minimum System Requirements:

    OS: Windows XP
    Processor: Intel Core 2 Duo 2.4 GHz or AMD Athlon X2 2.7 GHz
    Memory: 2 GB RAM
    Graphics: ATI Radeon 3870 or higher, Nvidia GeForce 8800 GT or higher. 512MB VRAM.
    DirectX®: 9.0c
    Hard Drive: 7 GB HD space
    Other Requirements: Broadband Internet connection

  • @BobT36:

    I think this may be your system specs, specifically your graphics card…

    I highly doubt that is the problem, I played the game before with only minimal lag and no issues whatsoever.
    Come to think of it, all my games have started giving me issues too, but none that are as severe as preventing me from playing them.

  • After cleaning up my computer, Getting rid of at least 15+ GB of stuff, doing a full system scan with two different antiviruses, and ending multiple performance reducing useless processes, my other game problems were fixed, and performance has improved. Chivalry, however, still refuses to work properly.

  • The problem is that Chivalry is only detecting one CPU when clearly you have more than one core in the i5.

    From your Launch.log:

    [0000.50] Init: CPU Page size=4096, Processors=1

    Check this thread for someone with a similar issue who fixed it: viewtopic.php?f=69&t=8126

    His specific solution:

    I managed to get 4 now i said to open msconfig in the start menu go to boot then advance settings and un-tick the number of processor box

Log in to reply