Option for Toggle Aim (so you have to hold)



  • There really should be an option to set Aim to a non toggle button, so you have to hold it, as well as an option to toggle Zoom on or off like the option for Sprint. I for one like to hold “aim” and don’t want to have to hold down zoom as well.

    For example, the spring has bUseToggleSprint=False you can use so you have to hold Spring. We need the same thing for Zoom!

    Edited for clarification cuz I was confused about aim/zoom



  • I would love this as well, in-game I keep saying to myself, “I wish there was toggle zoom,it would makes thing easier for me I think.”



  • I’m not exactly sure what you are asking for.

    If you are asking for the ability to only zoom in with the crossbow while holding the right mouse button (or whatever you bound it to) and for the zoom to release/zoom out when you let go of the right mouse button, do this:

    In UDKGame.ini in Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config, change the line for GBA_Aim to be this:

    Bindings=(Name="GBA_Aim",SecondaryKey=,Command="PerformAim | Onrelease PerformAim",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag=,FriendlyName="Unknown")
    
    


  • I guess I was confused with the controls since the default controls have Aim and Zoom set to the same key. Your suggestion worked for what I wanted, but now I wish the Zoom was now a toggle and that doesn’t seem possible with the same method, any suggestions?

    Bindings=(Name=“GBA_Zoom”,SecondaryKey=,Command=“ZoomInOut true | Onrelease ZoomInOut false”,Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag=,FriendlyName=“Unknown”)

    It seems to me that’s already setup to not zoom back out on release, so I don’t know what to do to make it stay zoomed until I hit the key again or fire.

    Edit: Bind you gave me isn’t working 100%, if you reload right after firing (while still “aimed”) it goes back into aimed mode after it reloads the CrossBow. Also if you don’t hold the key down long enough it stays Aimed.



  • @chicken-:

    I guess I was confused with the controls since the default controls have Aim and Zoom set to the same key. Your suggestion worked for what I wanted, but now I wish the Zoom was now a toggle and that doesn’t seem possible with the same method, any suggestions?

    Bindings=(Name=“GBA_Zoom”,SecondaryKey=,Command=“ZoomInOut true | Onrelease ZoomInOut false”,Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag=,FriendlyName=“Unknown”)

    It seems to me that’s already setup to not zoom back out on release, so I don’t know what to do to make it stay zoomed until I hit the key again or fire.

    Since the crossbow doesn’t have zoom (that I know of?), I assume that you mean with the bow? So if I understand you correctly, you want to be able to aim (Left Mouse Button) and then zoom IN by hitting the right mouse button WITHOUT holding down the right mouse button. Then you can zoom OUT by hitting the right mouse button again. Is that correct?

    @chicken-:

    Edit: Bind you gave me isn’t working 100%, if you reload right after firing (while still “aimed”) it goes back into aimed mode after it reloads the CrossBow. Also if you don’t hold the key down long enough it stays Aimed.

    Going back into aimed mode happens by default… I don’t know about that.

    Yeah I saw the not holding down long enough thing… I don’t know what to say to that other than get used to it? :)



  • The toggle zoom thing I can live without, but it should be an option, NOT having to toggle aim should definitely be added. And yes you can zoom while in aim mode with the crossbows.

    I like having to hold my “aim” key, which works as you have it, but the problem is if you fire and immediately reload while its still in “aim” mode, it automatically goes back into aim after it reloads, which gets me killed cuz I’m not used to having to hit a button to get out of aim mode.

    It wouldn’t be so bad if hitting sprint cancelled out the aim mode, but I end up getting nailed trying to sprint while in aimed mode.

    Do they ever fix anything anyway, is it a waste of time to even post about issues/suggestions. I see posts from back in November regarding the server browser and that’s still completely messed up/inaccurate.



  • @chicken-:

    The toggle zoom thing I can live without, but it should be an option, NOT having to toggle aim should definitely be added. And yes you can zoom while in aim mode with the crossbows.

    Huh. It defaults to Aim and Zoom on the right mouse button for me. So if I aim with the crossbow and hit right mousebutton again, it stops aiming. I guess the solution would be to separate them to different keys. Not having to toggle aim… I just provided the solution to you.

    @chicken-:

    I like having to hold my “aim” key, which works as you have it, but the problem is if you fire and immediately reload while its still in “aim” mode, it automatically goes back into aim after it reloads, which gets me killed cuz I’m not used to having to hit a button to get out of aim mode.

    If you’re holding the “aim” key, why not release then reload? You’re not hitting a button, just releasing a button… It’s not making sense to me why you would hold the aim key and hit reload if you don’t want to be in aiming after reloading.

    To change that behavior is something that the devs would have to fix. Which would be a low priority at this point.

    @chicken-:

    Do they ever fix anything anyway, is it a waste of time to even post about issues/suggestions. I see posts from back in November regarding the server browser and that’s still completely messed up/inaccurate.

    They absolutely do. The patch coming this month fixes a lot of bugs. The server browser is a unique beast. It’s not actually the server browser, it’s the servers. The devs are working on it. It’s Bug #1 right now with the hopes of getting it into this big patch.



  • They said they were fixing server browser in November… I don’t have high hopes. Unreal engine games are very uncomplicated when it comes to servers/querying, so I don’t buy that excuse at all. Somehow a billion other unreal engine games work just fine but they have to take 3-4 months to fix it.

    Anyway, as far as the Aim stuff, I can’t explain why I do what I do other than that I’ve been playing FPS games of every kind since Wolfenstein 3d and I’ve grown accustomed to things working in a certain way. In every other game I’ve ever played with any “Aim down sight” type of control, reloading breaks that and doesn’t just put you back into that mode afterwards. Any other control should “break” the aim mode, sprinting or changing to another weapon and it doesn’t seem to always work that way.

    This is 2013, people should have appropriate options to set their controls so they feel comfortable, this isn’t something that is new, it’s been in games for a decade and I know the unreal engine is easily capable of this if they’d just update the bind list with a different method of GBA_AIM.



  • @chicken-:

    They said they were fixing server browser in November… I don’t have high hopes. Unreal engine games are very uncomplicated when it comes to servers/querying, so I don’t buy that excuse at all. Somehow a billion other unreal engine games work just fine but they have to take 3-4 months to fix it.

    The server browser was fixed. A new bug popped up and it’s in the servers that are reporting incorrectly to everyone that queries them whether or not you use the in-game browser or not. Send the raw UDP query packets to see for yourself.

    You sound knowledgeable on programming the Unreal Engine 3 and Steamworks. The dev team only has two programmers. Send your resume to them and fix it.



  • Only two programmers on the dev team? Fuck me!

    Is there a donate button around somewhere.



  • @lemonater47:

    Only two programmers on the dev team? Fuck me!

    Is there a donate button around somewhere.

    Just buy more copies of the game 8-)


Log in to reply