Is there anyway to reconfigure a Xbox Controller?

  • I’ve gone into Steam/Steamapps/common/chivalrymedievalwarfare/Engine/config/BaseInput

    Changed the xbox commands in all 3- and in game the controls still play as the defaults. This incredibly frustrating as the default controls feel very out of place, I would love to know if I’m missing something I can use to alter the controls or if I’m just going to be stuck with the default controls.

    Now, before someone asks, no, I don’t have anything against playing with PC controls, but it’s kind of awkward to be playing on my living room TV with a keyboard and mouse set up.

  • Go into your Documents/My Games/Chivalry Medieval Warefare/… and go into the Config files there & edit them. Those are the cfg’s the game really uses on your system… the others are like default backups or something like that.

    When you made audio/graphical settings in the game, the cfg’s in the above section of your system are where they are saved.

    If you had another account on your system and tried to play the game from that user account, you’ll notice that when it loads up, everything is set to their default settings, which is because it’s loading up the settings in that person’s Documents/My Games/ folder rather than the one you normally use and already changed.

  • Thank you for your response, I was already going into the documents you suggested, but just taking a longer route.

    I was able to fix my problem by going into the UDKGame and changing the input settings from there.

    Once again though, thank you for trying to help.

  • Download a 3pp to map the controler’s buttons to the keyboard commands, I think microsoft has software for such a task.

    I remember doing something like this for MW2, brb w/ link.

  • Is there any way to adjust the sensitivity when using an Xbox 360 controller?

  • @Zhou:

    Is there any way to adjust the sensitivity when using an Xbox 360 controller?

    Sure is. In your UDKGame.ini (found in Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config), edit the “speed” in these two lines. Default is 1.0 for left/right and 0.65 for up/down. An example of a really high number is 10.0. Sooo I’d look for somewhere in the 3-4 range maybe?

    Bindings=(Name="GBA_TurnLeft_Gamepad",SecondaryKey=,Command="Axis aTurn Speed=1.0 DeadZone=0.2",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag=,FriendlyName="Unknown")
    Bindings=(Name="GBA_Look_Gamepad",SecondaryKey=,Command="Axis aLookup Speed=0.65 DeadZone=0.2",Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag=,FriendlyName="Unknown")

Log in to reply