[SOLVED] Odd performance with Chivalry from when I bought it



  • Hello All,
    I bought Chivalry Medieval Warfare around when it came out. I had a blast. I loved age of chivalry and followed its development at PAX. I recently wanted to show my friend Chivalry and show him why I liked it and it ran really slowly. Even with all low settings, it ran all slowly. This was odd because when it came out it ran fine on my i5 machine with an ati 6670 card. and now the same install does not run fine. What should I do? The only thing that changed was I now have a second monitor? Does unreal not like second monitors? Should I reinstall?

    Thanks



  • If you’re using dual monitors on a 6670, it may be screaming for mercy. Chivalry isn’t the most optimized game, and the 6670 wasn’t made for dual screen gaming.



  • good point, I guess a 2 screen setup with an ok card and Chivalry might not have been the best idea. If i put it in windowed mode it does work however for those who have this issue.



  • I usually play in 1280x720, windowed mode. With my 6670, it runs it pretty well then. With all medium settings, no dynamic shadows, but with Depth of Field and motion blur.



  • @timetopat:

    good point, I guess a 2 screen setup with an ok card and Chivalry might not have been the best idea. If i put it in windowed mode it does work however for those who have this issue.

    Glad you got it working. Chivalry is a bit wonky with multiple monitors and multiple GPUs (SLI/Crossfire). :?

    I’m marking this one solved :)


Log in to reply