Unlock glitches



  • To my knowledge, you unlock new weapons via kills for that weapon group. However, I seem to be stuck on a few weapons. Originally, I had problems with both the Blunt primary group for the Knight, as well as the Sharp secondary group for Archer/Man at Arms/Vanguard. I was stuck on 5 kills for the Grand Mace, and 6 for the Saber, regardless of how many kills I scored with their respective weapon groups. However, I seem to only have the Saber unlocked for the Vanguard class, whereas it says I’m on 6 kills to unlock it on Man at Arms/Archer. I ran into the problem where no servers would display on the browser, but solved it by uninstalling and re-installing. After doing so, I quickly unlocked the Grand Mace for the Knight, but the Saber is still locked for the other classes besides Vanguard. Is this a problem that can be solved on my side, and if so, how? If not, is this something that’s going to be addressed in the next patch?



  • Weapons like Sabre have to be unlocked for each class you want to use it on.

    So the kills on MAA are independant of those on archer, etc.

    If you’re getting stuck with the counter not going down at all though on that same class, try joining an official server, getting a couple of kills, then going back to the one you were on. That seemed to work for me when I had that problem the other night.



  • @BobT36:

    Weapons like Sabre have to be unlocked for each class you want to use it on.

    So the kills on MAA are independant of those on archer, etc.

    I never knew that, but I’ve been playing as Man at Arms for the past hour and gotten ~30 kills, all with a shortsword, and still nothing. I guess I’ll have to find an official server.

    EDIT: I’d also like to note that not once have I ever pulled out a secondary weapon for the Vanguard (lol who needs to when LMB to victory with a primary), yet I had Saber unlocked for it first.



  • That’s strange, I could swear it’s independant of class. I’d have to double-check though haha, which I can’t do at the moment.

    As to the official servers, they’re labelled with exactly that in the server name, official LTS server, official classic server, etc, hosted by multiplay.

    After joining one of those and coming back, let us know if you still have trouble. Deleting one of the config files may help. It could also be that the particular server you’re playing on needs to be restarted.



  • Playing on an official server totally fixed the problem. Thanks!


Log in to reply