Window Focus Lost with Dual Monitors



  • When you play with more than 1 monitors and you drag your mouse and attack it happens a lot that you tab out the game.

    Makes it absolutely unplayable for me, needs fix asap.



  • Can you give some specifics on your setup please? So the devs actually have something to go on when attempting to fix your issue.

    Mainly by going to Start > Run > DxDiag > Save All Information, and attaching the log here.

    Also are you running in Windowed or Full Screen mode?

    I have also modified the topic title, attempting to insult the devs won’t get you anywhere.



  • I run the game in full screen, sorry for overreacting but the bug is really annoying if you are right about to chop someones head off and then the game minimizes :x

    Also I run the game in full screen mode



  • I have dual monitors but don’t have this problem. I have an nVidia card if that makes a difference.



  • Yeah I run dual (even with my secondary on the left), and have had the mouse go out of the game window in some games, but Chiv is fine for me, in Full Screen mode at least.

    I wonder if it is just ATI cards then?

    Cheers for posting your setup, it will help the devs. Unfortunately don’t have an ETA on any of that at the mo though. A patch is coming out soon so this fix MAY be included, can’t guarantee at this point though.

    Try the Beta maybe in the meantime? See if it’s fine on that. :)



  • Works fine for me (Nvidia card, three monitors).



  • I have an AMD card as well. This sometimes happens when I have other programs running in the background (not necessarily on the second monitor) and usually happens when I forget to close the editor.

    Also, try running it in borderless windowed mode.

    “Originally posted by Vesros:
    You can add “-borderless -resx=1920 -resy=1080” to your launch options right here in steam aswell, go into your library, right click chivalry and go into properties.
    In the general tab click on launch options and add the line above. Customize the resolution options to your monitor and enjoy!”



  • I just remembered that I don’t have this problem on another pc I play on and it has an ati card.