Server cannot be found



  • Hi,

    I tried to run a dedicated server on my own PC. I used

    UDK.exe AOCTD-Moor_p?steamsockets -maxplayers=15 -dedicated=true -seekfreeloadingserver -Port=7777 -QueryPort=27015 -multihome=79.197.xx.xx (my current ip)
    

    I also tried leaving out any of those parameters one by one. Tried all combinations.

    My Firewall redirects Ports 7777-7780 (UDP/TCP) to my PC and 27000-27040 (for Steam Servers). Since today all of my Steam Servers ran with no problems (Magica, Dead Island, Crusader Kings 2 and so on).

    My Server can be accessed by the game via console “open 127.0.0.1” but not via “open 79.197.xx.xx”. Even “open 79.197.xx.xx:7777” does not work.

    Should that work? How can my friend join my server, if it does not show up in the server list?

    Of course no other Steam Server is currently running. Also I tried a completly different port (8877) with the same result. Also I tried changeing the queryport. No difference.

    My serves shows up correctly in the steam server browser in the “LAN” tab, but does not show up (same with all other chivalry servers) in the server tab.

    So i tried downloading the MasterServer2.vdf. Same result (none).

    The only strange thing I noticed is, that a fried of mine does have a slightly different Serverlist in the game than me.

    And netstat -a does only show: UDP 0.0.0.0:27015 :
    I am not sure what that means.

    Does anyone have another Idea?



  • I’d imagine your ports are correctly directed through your router as well.

    Have you tried adding those properties to and running UDKLogging.exe? At least then you’ll get text to go along with your server start-up procedure; Might be able to better identify the problem.



  • @Ancillius:

    Hi,

    I tried to run a dedicated server on my own PC. I used

    UDK.exe AOCTD-Moor_p?steamsockets -maxplayers=15 -dedicated=true -seekfreeloadingserver -Port=7777 -QueryPort=27015 -multihome=79.197.xx.xx (my current ip)
    

    multihome=

    This needs to be your internal IP address, not the WAN (unless you have a very unique/uncommon local IP address range)

    My Firewall redirects Ports 7777-7780 (UDP/TCP) to my PC and 27000-27040 (for Steam Servers). Since today all of my Steam Servers ran with no problems (Magica, Dead Island, Crusader Kings 2 and so on).

    Ports are correct, no issue here.

    My Server can be accessed by the game via console “open 127.0.0.1” but not via “open 79.197.xx.xx”. Even “open 79.197.xx.xx:7777” does not work.

    Take note of the multihome issue above.

    My serves shows up correctly in the steam server browser in the “LAN” tab, but does not show up (same with all other chivalry servers) in the server tab.

    Don’t use the Steam server viewer, it doesn’t even have support for Chivalry.

    Also, check out the guide I wrote in my signature, might have missed something else small.



  • Hi all,

    thanks for your answers at first.
    Secondly we have an update. I changed the queryport to 7778 like in you batch file. And then i used UDKLogging.exe to see what is going on.

    Interesting thing is, now after a while my server is running at average of 20 Players.

    I attached the logfile.

    But still “open 79.xxx.xx.xx” (WAN IP) does not work.

    Since i added -multihome 192.168.0.11 (my local IP) “open 127.0.0.1” does not work but “open 192.168.0.11” does.

    But still i can not see my own server in the server list. The guys playing on my server and a friend of mine can see it.

    What am I missing?

    PS: Added the log, maybe one can see something there.
    Servername is bane: feel free to check out.

    Edit: I just saw the attachment does not show… i will see to get a dropbox account to upload it…



  • @Ancillius:

    But still i can not see my own server in the server list. The guys playing on my server and a friend of mine can see it.

    What am I missing?

    Not really missing anything, I wouldn’t quite call this a bug, especially if others can see and join the server. I have a similar problem sometimes, my server just flatout won’t show in the server list unless I spam refresh a few times.

    If you’re not running port 7777 for the game itself, specify that in your command, example: open 79.x.x.x:7778

    Change according to what you have. However, you shouldn’t even have to do that, because it should be showing in the server list.

    PS: Added the log, maybe one can see something there.
    Servername is bane: feel free to check out.

    Didn’t get the attachment. I jumped in Chivalry real quick, but I couldn’t find any games with the name “bane” - I let it do a complete search.

    If other players are on, you might have the port forward issue, some players get through, some simply don’t. The only thing I can suggest is changing the QueryPort to 27025 (PCServer-UDKEngine.ini) and make sure you haven’t changed the PeerPort or the game Port to anything that could conflict.

    I’ve found that the default Port of 7777 and the PeerPort of 7778, the QueryPort though, is at a default of 27015, I’ve found that this needs to be 27025 for the server to work correctly.

    Other than that, I’m more or less out of ideas.



  • I will try… thanks again.



  • In Game I also could not see my new Dedicated Server for nothing.

    I can see now by doing this:

    Make everything default in Server Filters which is everything unchecked a lot of ALL this that.

    I then set max ping 200 and refresh - Nothing…

    I then Hide Passworded Servers and Wallah it shows up.

    Must be only so many can fit in there?



  • That could be an explaination.