Latency issues are killing this game



  • It is not uncommon for me to have more than half the arrows I shoot disappear entirely. It is extremely frustrating, and I’m appalled that this hasn’t been addressed. On smaller games, with fewer people, I have more reliable hits with my arrows (65% or so accuracy) but on larger games I see my arrow disappear after about 10m, or when it collides with an enemy model.

    I have no latency problems in other games, and my computer can run everything maxed, so I have to assume it is the game’s problem. Is there anything I can do about this? I know it isn’t just me because friends have noticed my arrows noclipping as well, and of course we all have the failed block happen. Every now and then I have weapons get stuck out, or my block gets stuck up, etc. Ping is around 80, since I can’t find a server that has anything better.

    I really want to enjoy this game, but I am about to quit entirely and give up on it because of crap like noclipping arrows. Archery in this game is challenging enough without my arrows deciding to go through my targets without damaging them.



  • Latency is your problem, change your isp or get a better deal if you want a better connection, i have 50+ servers with less than 80 ping and i live in Australia where the internet is complete dogshit. (though the governments rolling out an nbn so thats cool)



  • Except I have no issue on any other game. Over 30mb/s down and usually, on every other game but Chivalry, I have a ping of around 30 or so.

    Is there something wrong with my ports that is unique to Chivalry? I’m not the only one having problem with this; several of my friends here in Texas quit playing because they got so frustrated with it. Glaring problems such as this ought to be at least acknowledged or the playerbase will wane quickly.



  • @Tankcommander:

    Except I have no issue on any other game. Over 30mb/s down and usually, on every other game but Chivalry, I have a ping of around 30 or so.

    What are your pings on Chivalry servers?



  • Even on low ping servers I have enemy stop rendering, stuck in block…but your shield isnt really up…, and attack combos that get qued and happen 3 seconds later when youre trying to block lol Sucks



  • I played some singleplayer yesterday and was amazed at how much better I did at archery and in general….all my attacks were landing properly, so it has to be lag of some short.

    @ReMixx:

    @Tankcommander:

    Except I have no issue on any other game. Over 30mb/s down and usually, on every other game but Chivalry, I have a ping of around 30 or so.

    What are your pings on Chivalry servers?

    Currently I’m averaging 85, on server browser I can never find anything less than 90, and typically in game they have been 110-130, with the occasional 80. Never lower than that tho, which is strange since 80 is normally high for me in other games.



  • I usually get around 80-100 as well. But don’t really get stuff you describe very often. I do however have a friend who has teleporting issues.

    Have you ever done a packet loss test?
    http://pingtest.net/
    This will tell you the reliability of you ISP, not just the speed.



  • A-, with 60ms to a server 2 hours away.

    I played SP and was amazed at how well the game played….I go online however, and it gets frustrating. All three of my Texas friends have the same issues, so maybe that’s a factor?


Log in to reply