Need HELP .Cant play the game.



  • Hello, as the title says i cannot play the game for some reason…
    I also got this error when first time launching : "Out of video memory (or something like this)

    Im quite sure that i should be able to play it because i have :

    CPU: Intel® Core™ i5 CPU 750 @ 2.67GHz
    Video/Graphics card: GeForce 9400 GT
    Pixel Shader version 4.0
    Vertex Shader version 4.0
    Dedicated Video RAM 1.0 GB

    edit Checked and saw that my video card drivers are up to date.



  • Bump



  • @kalmusenator:

    Dedicated Video RAM 1.0 GB

    From your DxDiag.txt:

    ---------------
    Display Devices
    ---------------
            Card name: NVIDIA GeForce 9400 GT 
         Manufacturer: NVIDIA
            Chip type: GeForce 9400 GT
             DAC type: Integrated RAMDAC
           Device Key: Enum\PCI\VEN_10DE&DEV_0641&SUBSYS_055110DE&REV_A1
       Display Memory: 512.0 MB
    

    You only have 512 MB of video RAM. BUT that should be okay according to the minimum requirements… as the min is 512.

    Please attach the latest .dmp file in the same location as the Launch.log.



  • Hmm, well the only dump file i found is here.



  • bumpidy



  • The crash .dmp call stack includes

    user32.dll!_GetMonitorInfoA
    

    This is point me to something with your video card/drivers or monitor.

    Okay a few things. First, update your video card driver to the latest Jan 5, 2013 WHQL driver: http://www.geforce.com/drivers/results/55216 (double check that that is the right one for your card and OS).

    Try Chivalry again.

    If it fails, try setting the launch parameters for the game in Steam to this:

    -windowed -resX=1024 -resY=768
    

    If it still fails, please attach brand new DxDiag.txt, Launch.log, and crash .dmp files.

    If you reach this point, would it be feasible to reinstall Steam and Chivalry onto your C: drive as opposed to your F: drive? Some people experience problems when they are not on the C: drive (assuming that C: is your primary Windows installation drive).



  • Ok, i am going to try all this, but about installing it to C: if everything else fails, i will try that. And to add this: When running chivalry, it just freezes upon the black screen after torn banner ad, and i gotta restart…



  • @kalmusenator:

    And to add this: When running chivalry, it just freezes upon the black screen after torn banner ad, and i gotta restart…

    Restart your computer?

    Also, does it exhibit any different behavior if you start the game from the UDK.exe directly instead of through Steam?



  • Ok, running the game with the steam launch properties code gave me this error .```
    "Rendering thread exception:
    Direct3DDevice->CreatePixelShader((DWORD*)&Code(0),(IDirect3DPixelShader9**)PixelShader.GetInitReference()) failed
    at C:\Development\chivalry - patch\Development\Src\D3D9Drv\Src\D3D9Shaders.cpp:20
    with error 88760028

    Address = 0x7c812afb (filename not found) [in C:\WINDOWS\system32\KERNEL32.dll]
    Address = 0x493f21 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x650064 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x650064 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x2e0072 (filename not found)
    Address = 0x650047 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x490074 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x69006e (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x520074 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x660065 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x7c809e15 (filename not found) [in C:\WINDOWS\system32\KERNEL32.dll]
    Address = 0x40d4e0 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0xe50619 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x650064 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x650064 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x7c91005d (filename not found) [in C:\WINDOWS\system32\ntdll.dll]
    Address = 0x7c8099fa (filename not found) [in C:\WINDOWS\system32\KERNEL32.dll]
    Address = 0x7c809a0d (filename not found) [in C:\WINDOWS\system32\KERNEL32.dll]

    Didn't redownload or place at C:\ drive just yet.
    Drivers are latest. But! I am running the computer with 2 operation systems, both installed on seperate harddrives (Xp and Win7).


  • @kalmusenator:

    Ok, running the game with the steam launch properties code gave me this error .```
    "Rendering thread exception:
    Direct3DDevice->CreatePixelShader((DWORD*)&Code(0),(IDirect3DPixelShader9**)PixelShader.GetInitReference()) failed
    at C:\Development\chivalry - patch\Development\Src\D3D9Drv\Src\D3D9Shaders.cpp:20
    with error 88760028

    Address = 0x7c812afb (filename not found) [in C:\WINDOWS\system32\KERNEL32.dll]
    Address = 0x493f21 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x650064 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x650064 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x2e0072 (filename not found)
    Address = 0x650047 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x490074 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x69006e (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x520074 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x660065 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x7c809e15 (filename not found) [in C:\WINDOWS\system32\KERNEL32.dll]
    Address = 0x40d4e0 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0xe50619 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x650064 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x650064 (filename not found) [in F:\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32\UDK.exe]
    Address = 0x7c91005d (filename not found) [in C:\WINDOWS\system32\ntdll.dll]
    Address = 0x7c8099fa (filename not found) [in C:\WINDOWS\system32\KERNEL32.dll]
    Address = 0x7c809a0d (filename not found) [in C:\WINDOWS\system32\KERNEL32.dll]

    Maybe it was typed in incorrectly? :?

    @kalmusenator:

    But! I am running the computer with 2 operation systems, both installed on seperate harddrives (Xp and Win7).

    Okay. I’m not sure to the extent of how placing it in the C: drive helps yet (for those that it solved their problem). I’m guessing that C: is your windows 7 drive? Any reason why you use XP for gaming instead of Windows 7?

    Is this new Launch.log and crash .dmp file from after running it with the command line properties…? The .dmp file is showing an exception being raised while trying to free memory with a local function… that doesn’t help much :x



  • Well, i am using Win xp most times, and thats also why im playing with that os. And the new files are after both running udk.exe and with the command line settings (if i remember i last run it from udk.exe directly. Produced a black screen and non responsive computer. If i ran it with steam and command line, it was windowed and produced out of video memory error that i could close and carry on using computer.



  • bump and also i think this is most definetly ont my computers fault, because i can run most games with medium to high graphics.



  • bump



  • I need help with this god damn -_-



  • BUMP



  • Attach the latest Launch.log, DxDiag.txt, and crash .dmp and let’s see where we’re at.



  • Oh, well it seems that somehow it magically got fixed. I reinstalled once more on the Win7 OS, and am running it in window mode and it seems to work fine. I dont know, if theres been any patches meanwhile i didn’t try it, or what, but its fixed as of today.



  • @kalmusenator:

    Oh, well it seems that somehow it magically got fixed. I reinstalled once more on the Win7 OS, and am running it in window mode and it seems to work fine. I dont know, if theres been any patches meanwhile i didn’t try it, or what, but its fixed as of today.

    Last patch was January 31. There was a small localization fix pushed out yesterday (Feb 12th), but that just changed text stuff.

    Okay, I won’t mark this solved for now as we’re unsure if it will continue to work or not.


Log in to reply