Chivalry won't launch



  • Hello forums, its me again, seeing as how no one answered this question before, im assuming no none knows how to fix it…… but i will try again. I recently acquired Chivalry: Medieval Warfare but it won’t launch. I bought it for 50% off, and as soon as it finished downloading i attempted to play it. When i hit the launch button nothing happened, but my friends said my steam status said i was. I have looked at some solutions but they all require a folder within the “My Documents” folder. This folder was said to be called “My Games”. I looked for it but i couldn’t find it on my computer, and i dont know what to do. Im running windows 7 home premium if that helps fix this problem.

    Please help, and many thanks

    -General_Fou



  • Deleted your first post. Please don’t post duplicate posts. Bump if necessary.

    If you don’t have C:\Users<username>\Documents\My Games\Chivalry Medieval Warfare, it’s because Chivalry didn’t successfully launch for the first time yet.

    Please attach your DxDiag.txt in a reply here.

    Is Chivalry installed on a different drive from C?</username>



  • Yes Chivalry is installed in the C:



  • @General_Fou:

    Yes Chivalry is installed in the C:

    First thing’s first. Please update Windows to Service Pack 1 (check for updates again after installing updates as some updates need other updates to be installed first before being available). Then install the latest video card drivers from AMD’s website.

    Report back if Chivalry works or not after that.



  • OK, its sayin it needs a hour to download, be back then.



  • @General_Fou:

    OK, its sayin it needs a hour to download, be back then.

    Sounds good. I may be asleep then, so I may have to get back to you tomorrow or later (assuming that the updates don’t fix it outright). Someone else may jump in though.



  • Thanks ReMixx, you helped mt friend last night, and told me to hope for you! Thanks (even if it doesnt work XD)



  • @General_Fou:

    Thanks ReMixx, you helped mt friend last night, and told me to hope for you! Thanks (even if it doesnt work XD)

    :)



  • Ok, so what i have to do is go to the chivalry files and right click the UDK.exe and click run as administrator for it to launch. It works like that but when i try to launch it through steam it doesn’t work, and i need steam for multiplayer :/

    Again many thanks



  • @General_Fou:

    Ok, so what i have to do is go to the chivalry files and right click the UDK.exe and click run as administrator for it to launch. It works like that but when i try to launch it through steam it doesn’t work, and i need steam for multiplayer :/

    Again many thanks

    Does it still give the same problems as your original post? Would you please attach a new Launch.log and DxDiag.txt? Since you were able to launch the game, you should have that folder now. Please try launching the game from Steam before you attach the Launch.log too so that it grabs info from the Steam launch.



  • I couldn’t find the launch log, and the my games folder still hasn’t appeared.


Log in to reply