Chivalry Lag On Medium - High End System??!!!



  • Hi, I got chivalry a month or two ago and really enjoy it. But when ever I play the game even on lowest settings, the game plays at around 60 most of the time, then after a while the game will drop all the way to 15 - 20 fps!!! Obviously this is a problem. Here are my specs:

    CPU : AMD FX Bulldozer 8150 Octacore 3.6GHz
    GPU : MSI Radeon HD 7770 1GB
    RAM : 8GB Corsair XMS3
    PSU : Powercool extreme cool 550W
    MOBO : ASUS M5A78LLE

    Please if you know a solution please reply to this topic, it makes the game almost unplayable.

    PS. I am getting a after market heatsink next thursday and will over clock to 4 GHz. Will test some more games and put results here!



  • bump



  • Octacore CPU

    Uhh, I don’t think that Chivalry would actually utilize all 8 cores, in fact, it may even lower performance.

    Try this:
    1. Start Chivalry
    2. Open Task Manager and select UDK.exe
    3. Right Click and select “Go to Process”
    4. Right click on UDK.exe’s process
    5. Click set Affinity
    6. Select your processor cores to utilize only 4 cores for UDK.exe
    7. Apply and exit Task Manager.

    I had a similar problem with Assassin’s Creed II, as it doesn’t take Quad Core processors all that well, so I had it utilize only 2 cores. Surprisingly, this game me an FPS boost in it.

    Not a whole lot of games support 8 cores from a single processor, personally I think 8-cores would just be for show. :?



  • Its closer to Low-Mid end. My 680 is considered Mid-High End by some lol.



  • You say after awhile your FPS plummets. Are you monitoring your temperatures? Perhaps something is throttling. Keep an eye on CPU/GPU temps while in game.


Log in to reply