Help is Needed (App Already Running)



  • Hi guys I appreciate you for reading this and I need your guy’s help! OK when I click play to play Chivalry it does the normal first start up thing every time Mmk? then that finished and nothing happens I click it again nothing still, then I go to the Chivalry desktop Icon and click that nothing, Then I click it multiple times and it says App already Running. I’ve tried many thing and I just don’t know what to do I’m very frustrated and I just wanna try it out and see if i like it, if so I will buy it but now I cant the free weekend will be over in minutes and its the roll of the dice should I buy please guys give me suggestions for my problems thanks for reading this and please reply :)



  • So you don’t get to the title screen at all? With the Join Game, Create Game, Training, Configuration and Credits options?



  • Nope not at all I could possibley post a video of it



  • Press alt+ctrl+del and go to startk task manager > processes > search for chivalry click it press delete and restart the computer and should be fine :)



  • I dont see Chivarly in take manager D:



  • Somebody Please Help I just bought the game now I rolled the disc and I dont know If i choose the right chose. Please Help!



  • Issued Solved I got a shitty computer and I wasted my money my computer cant play it Oh well.


Log in to reply