Help me please



  • Hello Knights ! I have played Chivalry in this weekend for free and the game is awesome and I bought an invite and when I am trying to activate it it appears a error like this : This game is already in your game library.
    OK . But is not in my library :(



  • I’m having the same problem happen to me. Played a bit in the free weekend, decided to go in on a 4-pack but whenever I try to add to the library from my inventory it tells me “This game is already in your game library” even though it is not (I can’t play it or see it in my library under all games). If I try to play it from my recently played it just takes me to the steam page and wants me to buy it for a second time. I didn’t see this in the FAQ or any other threads (except the steam page ironically ) so I hope they know this is at least an issue!



  • Same issue as well, in addition to that, I can’t even join games. When I open it from my Steam folder and go to join a game, I get stuck at the “Please wait while the game loads” page. Really not sure what to do here.



  • Same problem here. When i try to add my Chivalry game,It says “You already have this game in your game Library”
    I want to play Chivalry……



  • Hi.
    I can’t activate my Chivalry Gift….
    After this awesome free weekend i bought Chivalry from friend and when this free weekend has finaly over i tryed 100000 times to add my Chivalry gift in my STEAM GAME LIBRARY. BUT its says “This game is already in your game library”. I checked everything and i didnt find CHIVALRY in my library.
    BTW after the Free Weekend i Deleted Chilvary from my Steam>steamapps>common>Chivalry, and tryed again to add it in my game lilbraly same problem “THIS GAME IS ALREADY IN YOUR GAME LIBRARY”
    I checked google and many peoples are with the same problem.
    Please help me. I want to play this unique game.
    Sry for bad spelling.



  • same problem, played on free weekend, liked the game, traded for a gift on tf2outpost, trying to “add game to my library” leads to “This game is already in your game library.” filled steam support ticket, waiting for answer on that one.

    But it’s clearly a license problem, you guys messed up with the free weekend, didn’t make license limit properly, or valve didn’t, i highly doubt it’s valve, it’s mostly indie dev. fault in such cases. Not bashing you or anything, just kinda waste of money, can’t even play it.


  • Developer

    We’re discussing this with Valve right now, your patience is appreciated.



  • Thank you CrustaceanSoup.



  • Any news there?



  • seems like they fixed it.



  • Not sure what you guys did but I logged in today and tried to add it and it worked fine no problems at all, thanks for the help!



  • I still have this problem here… I can’t join in the servers!


Log in to reply