Crash after Splash Screen [FIXED! Solution Below]



  • I’ve recently run into an issue where Chivalry crashes after the initial splash screen after i press play. It brings up the splash screen and then just crashes with no error report or anything. I have tried to use Steam’s “Verify game cache integrity” option but it just says everything’s fine, runs the first time setup, and then it just does the same thing, crash with no error. I even tried uninstalling and re installing the game with no luck. I’d appreciate some help with this issue. Thank You.



  • I’m having the exact same problem. I doubt people are going to help us anymore since those of us who have tried literally everything have practically no solution and there are already so many threads about this that people have just stopped trying to help altogether. My best guess is that this issue will (hopefully) be fixed by the next patch.



  • It doesn’t make a lot of sense to me because i was playing just fine for a few months now and ive even played after the new update. Heck i was playing yesterday, but today for some reason it wouldnt run :(



  • I was having the exact same problem and this fix worked for me!

    From a nice fellow named Schnurbinator on the steam forums.

    “I had a problem like this and I was able to fix it by going into the xfinity constant guard program and then to options, and manage my blocked programs rule and allowing isaac. My norton antivirus wasn’t blocking it but it looked like isaac was the only thing that the constant guard was blocking. After that the game loaded fine.”

    Just open constant guard, options, “manage my blocked program rules,” and check the allow button (for me both my binding of isaac and UDK were having the problem but changing udk cleared my Chivalry problem right up



  • Works like a charm. Why it decided to randomly block it is beyond me. Thats comcast for you…



  • This one worked for me as well, gonna copy and paste solution to my thread.



  • WOOT! Chivalry Community kicks ass :) Thanks guys worked perfectly!


Log in to reply