Chivalry Will Not Launch



  • I have constantly attempted to launch Chivalry, but it never gets past the little splash art. I have tried many fixes, like running vcredist in the redistchiv then running DXSETUP. I have tried verifying the game cache. I have tried running the UDK.exe. I have tried deleting the Chivalry: Medieval Warfare in the my games folder. I have even just re-downloaded the game. Yet none of this have fixed my problem. I get no error and running the Launch batch file doesn’t tell me that I am missing anything. This has been the case since I had exited out of the game by tabbing out and closing it (yeah, not really the proper way of doing it). I am really tired of going through all of these fixes and not getting any results. So if anyone can help with this it would be greatly appreciated!



  • I was having the exact same problem and this fix worked for me!

    From a nice fellow named Schnurbinator on the steam forums.

    “I had a problem like this and I was able to fix it by going into the xfinity constant guard program and then to options, and manage my blocked programs rule and allowing isaac. My norton antivirus wasn’t blocking it but it looked like isaac was the only thing that the constant guard was blocking. After that the game loaded fine.”

    Just open constant guard, options, “manage my blocked program rules,” and check the allow button (for me both my binding of isaac and UDK were having the problem but changing udk cleared my Chivalry problem right up.



  • Thank you! Finally Worked. Shoulda’ known it would be Constant Guard. That thing is bloody annoying. Crashing all the time, and popping up out of nowhere. Thanks again for the speedy reply!


Log in to reply