Sorry… but i CANNOT get my maplist working.



  • I apologize i know there are threads for this but i have tried numerous ways to get my maplist and it’s just not working. I am editing the correct file (i believe) which is PCServer-Udkgame.ini under UDKGAME/Config

    There is a section with maplist=(mapname)

    I have tried: removing ones i don’t want, save+upload to server, reboot… not working.
    I have tried: removing the whole list and adding maps i want (in correct syntax) save+upload… not working.
    I have tried: Adding numbers to the end in brackets for the map number like Maplist[1]=(mapname)… save+upload to server… not working.
    I also saw another thread mentioning defaultgame.ini. I saw ANOTHER maplist in here and got excited because i saw the map that was supposed to be set by the bluefang guy in the first spot on the list… followed by the maps i want. This apparently is not working. I also copied this list from this file in its correct formatting… and pasted it into the pcserver-udkgame.ini file in the correct location. Save+upload to server… not working.

    Each time i have ensured that the server is stopped. After save and upload i start the server, stop it again, and start it. It should get a full cycle. I have also rebooted a few times in between to see if that works.

    ALL of my other settings seem to hold EXCEPT the maplist. What am i doing wrong. I can change the admin password… i can change votekick settings/percentages, i can set limits… i can do everything BUT the maplist. Please someone explain to me.

    Maplist=AOCTO-Stoneshill_P
    Maplist=AOCTD-ArgonsWall_p
    Maplist=AOCTO-Battlegrounds_v3_P
    Maplist=AOCCTF-Frigid_p
    Maplist=AOCTO-Citadel_p
    Maplist=AOCTD-Frigid_p
    Maplist=AOCFFA-Darkforest_Valley_p
    Maplist=AOCTO-Hillside_P
    Maplist=AOCCTF-Ruins_Large_P
    Maplist=AOCTO-Darkforest_p
    Maplist=AOCLTS-Moor_Large_p
    Maplist=AOCFFA-Arena3_p
    Maplist=AOCTO-Darkforest_p
    Maplist=AOCTO-Battlegrounds_v3_P
    Maplist=AOCTO-Citadel_p

    This is what it looks like. This is currenlty under [AOC.AOCGame] at the BOTTOM of the list. I don’t know if the location matters but please let me know if it does because i think it’s in the same spot it was in by default, but it may have moved. I noticed some weird stuff after uploading, like the maplist went berzerk. Added stuff i didn’t put in all kinds of crazyness. Can someone either paste in their file (minus the admin password obvi or any sensitive stuff) so i can see what the heck i’m doing wrong. I am also using filezilla for ftp (even though that helps nothing really lol)

    Thanks! i really want to get this figured out. My Server is ‘Dost Thou Prate, Rogue? Reddit Chivalry’



  • Hi Clayton,

    How are you checking to see if your maplist is working?

    Things to keep in mind:
    1. The “maplist” console command is hardcoded. It does NOT reflect what the actual maplist is.
    2. The first map on the maplist may not get loaded depending on the command line you launch with. For example, my first map in the maplist is AOCTO-Citadel so my command line looks like this:

    AOCTO-Citadel_p?maxplayers=24?steamsockets

    I think your maplist may be working but you haven’t checked it correctly. Load your maplist, log into your server, login as Admin, and then type “aoc_endGame” into console. This will end the game and cycle to the next map. If the next map is part of your maplist, then it’s most likely working. I would keep using aoc_endGame until you’re sure it’s following your maplist.

    Also you’ll want to change your launch command line similar to mine above except for the first map on your maplist.

    Let me know if that helps.


Log in to reply