Stuck on "Please wait while the game loads", need help asap



  • First of all, I’m sorry if it sounds like I’m raging but I’ve got a problem that’s totally killing this game’s experience for me, so yes, I’m really pissed. When I try to enter a server from my country, most of them (I’d say more than 90%) are unjoinable, permanently… I’ll just get the “Please wait while the game loads” message and it will never load the fricking game. Even though there are always at least 5 servers full of players in Brazil, I am forced to play on foreign servers with a high latency, which will lead to a kick most of the times, and offensive comments from the other players.

    I need some help from support asap, this game is great and I don’t regret spending my money on it, but if I don’t get this problem fixed I’ll be forced to ask for a refund.



  • How long do you wait? One time I joined a server after like a minute of waiting just to see if it would work. If you can join one, you should be able to join any. Try restarting steam and waiting a minute to see if it ever connects.



  • How long do you wait? One time I joined a server after like a minute of waiting just to see if it would work. If you can join one, you should be able to join any. Try restarting steam and waiting a minute to see if it ever connects.

    I’ve waited over 5 minutes, it never joins… the problem must be on my end but I have no idea how to fix it. I’ve got several other multiplayer games on Steam and I never had any problems connecting to servers on any of them.

    Edit: Found these threads viewtopic.php?f=69&t=6356 viewtopic.php?f=69&t=4453&start=20 , I think it has something to do with my firewall/router, which may be blocking some data packets. Well, how do I fix it then? I’ve completely disabled my firewall and still didn’t work, and I’m not familiar to opening ports.



  • I assume that you’ve tried restarting Steam (I have to do that if I ever see that message which is rare but happens).

    You’re not from Brazil, are you?



  • @ReMixx:

    I assume that you’ve tried restarting Steam (I have to do that if I ever see that message which is rare but happens).

    You’re not from Brazil, are you?

    I have restarted Steam, this is a permanent problem I’m having since I bought this game two weeks ago. And it always happens with the same servers. I’m brazilian and I’ve never joined a foreign server that didn’t work, this only happens here, where 99% of the servers don’t work for me, but they do for almost everybody else.



  • @Shagrat:

    @ReMixx:

    I assume that you’ve tried restarting Steam (I have to do that if I ever see that message which is rare but happens).

    You’re not from Brazil, are you?

    I have restarted Steam, this is a permanent problem I’m having since I bought this game two weeks ago. And it always happens with the same servers. I’m brazilian and I’ve never joined a foreign server that didn’t work, this only happens here, where 99% of the servers don’t work for me, but they do for almost everybody else.

    Wondered why I asked if you were Brazilian? The Brazilian servers are notorious for problems with people connecting to them (especially the COLDFIRE ones). It’s something on their end that we can’t fix :|

    Also, things like Xfire (software app) can cause these issues too if you are running that.



  • I understand but, as seen on this thread viewtopic.php?f=69&t=4453 , this is not a problem that only we brazilians are facing. I don’t mean to be rude but you can’t tell me there is no way to fix it, if there are people playing on those servers (and there are many; two of them have 32 slots and are always full), then there must be a fix. There’s even a thread where a player claims to have solved this issue, although he didn’t explain much so it’s not really helpful: viewtopic.php?f=69&t=6356

    When something isn’t working inside the game, it’s the company’s job to help their customers fix it. And I (and many other players) require assistence now. Please.



  • @Shagrat:

    I understand but, as seen on this thread viewtopic.php?f=69&t=4453 , this is not a problem that only we brazilians are facing. I don’t mean to be rude but you can’t tell me there is no way to fix it, if there are people playing on those servers (and there are many; two of them have 32 slots and are always full), then there must be a fix. There’s even a thread where a player claims to have solved this issue, although he didn’t explain much so it’s not really helpful: viewtopic.php?f=69&t=6356

    When something isn’t working inside the game, it’s the company’s job to help their customers fix it. And I (and many other players) require assistence now. Please.

    The first thread is a zombie thread from October. Not useful to reference as not many details were provided with that (I joined these forums on the same day as the last post).

    The second post says that the guy changed his firewall to let it through. Disable yours and try again.

    Feel free to remove the line “Suppress=DevOnline” from your UDKEngine and then attach your Launch.log after trying to connect again as that guy did and I’ll take a look, but that’s all that I can offer. Those COLDFIRE servers are just notorious for being problematic for people trying to connect to them. They may have some misconfigured router or something which is totally on them.



  • I see, I’ll edit this post soon to attach the log. Thanks for the help.


Log in to reply