30fps on some maps, constant 60fps on others?



  • Hi,
    my problem with chivalry is, is that some maps (the harbour one, the one where you have to kill the peasants, the one with the trebuchets, and others) seem to have an fps lock at about 30, as i have low gpu usage (mostly <60% on my hd 5850) with a constant 29.x fps, as well as low cpu usage (overall usage usually around 40%, individual core usage around 50% on my 8x4ghz fx 8120) while on other maps (the duel map with the bridge, the one on the tower, throne room in ffa and lts an others) i maintain a constant 59 fps because of vsync.
    This problem is not affected by player count as it happens on 8 player duel servers as well as 32 player TO and FFA maps. I can’t imagine my cpu to be bottlenecking as it never is used more than 60%(even in BF3 on 64 player maps) and my gpu is also not being fully utilized. i have the latest drivers, and have always had the problem, but hoped it would be fixed in the patch.
    i run the game on full details, as changing the settings had no effect, although i never changed the resolution because i would expect that to be gpu limited.
    my specs are:
    fx8120 @4ghz
    hd 5850 1gb
    8gb ram 1333mhz
    1 tb caviar balck hd

    if anyone at least could tell me what the problem is i would be grateful, even if there is no solution to it, as i just don’t understand what would be holding the game back just on certain maps
    BTW i’m loving duel mode, so much more fun than other modes!



  • I don’t have a solution, just thinking out loud here. Seems like you get 30fps on the large TO maps and 60fps on the smaller maps.

    Do you have ambient occlusion or skylights turned on in your video settings? Something like ambient occlusion would do it, especially if it’s doing it to the whole map (big maps) even though you can’t see parts of the map yet due to the objectives not being completed yet.



  • The 30fps lock is a consequence of vsync. The game is attempting to render each frame in sync with the refresh of your monitor, which is 60 hertz. That means that in order to correctly sync, your PC must be able to render 60fps, otherwise a frame won’t be ready in time for the next screen refresh and the whole thing would fall in a heap. In this case, your PC is unable to keep up the required 60fps. To prevent problems, the game therefore drops your framerate to a factor of your refresh rate. It starts by halving it and renders each frame for two refresh cycles rather than one, thus maintaining sync. If performance were to get even worse, it would drop again to an even lower value, most likely 15fps.

    To fix the problem, you will need to either drop your graphics to a level where your system can maintain 60fps, or alternatively disable vsync in the game options. I’m going to strongly suggest the latter, because in all honesty, it’s not your graphics settings that are at fault here. Chivalry is badly CPU bound as a result of an excess of draw calls. That means that the CPU is unable to pass the data for each frame along to the video card in a sufficient amount of time, resulting in a low frame rate and low GPU utilisation. Hence why dropping your video settings doesn’t change much - things are getting easier for the GPU, but it wasn’t struggling to begin with, it’s already starved for work. The only fix is for Torn Banner to optimise their maps, their shaders, their weapon and character assets and such in order to drastically slash the number of drawcalls. Until that happens, performance will continue to suck.



  • Thanks Psycho_Ch!cken, turning off vsync and restarting the game seems to have solved the problem! i still don’t always get full gpu utilization, but it’s much better now!
    do you have any idea as to why chivalry handles vsync like that? no other game i’ve played so far had that issue with vsync halving your framerate when below 60, bf3 for example mostly runs at about 50fps on high settings, skyrim, batman arkham city, metro 2033, far cry 3 and others work perfectly fine with vsync too



  • @VoodaGod:

    Thanks Psycho_Ch!cken, turning off vsync and restarting the game seems to have solved the problem! i still don’t always get full gpu utilization, but it’s much better now!
    do you have any idea as to why chivalry handles vsync like that? no other game i’ve played so far had that issue with vsync halving your framerate when below 60, bf3 for example mostly runs at about 50fps on high settings, skyrim, batman arkham city, metro 2033, far cry 3 and others work perfectly fine with vsync too

    I’ve encountered it in black ops 2 and FEAR3.


Log in to reply