I don't understand why this game runs so poorly… Help?



  • I’ve been playing the game for the last few weeks now and even with the latest patch this game just has terrible frame rates always dipping below 20. I’ve tried going into the config file and turning off “frame smoothing” and boosting the MAX frame rate to well above 40, but still I don’t understand how other people can max the game and have it play flawlessly when my PC absolutely exceeds the systems specs in order to play… While I’m only playing at Low/Med Settings at 1360 x 1080? And suffering and making if difficult to play.

    System Specs:

    CPU: Intel® Core™ i7 CPU 870 @ 2.93GHz

    RAM: 8.2 GB

    OS: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit

    Video Card: ATI Radeon HD 5700 Series Pixel
    Shader version 5.0
    Vertex Shader version 5.0
    Dedicated Video RAM 1.0 GB

    Sounds: AMD High Definition Audio Device

    And about 900 Gigs of free storage space

    So what is it about this game that makes it so difficult to run for my system?

    I have all the latest drivers, I have no malware on my PC and it’s clean. Every other game I run, plays fine. I went onto “Can I Run It . com” and the report says my PC is at the max for performance for this game so I don’t understand it.

    If anyone could please help I would appreciate it, thanks!



  • @NightBlade87:

    While I’m only playing at Low/Med Settings at 1360 x 1080?

    What the heck kind of resolution is that?!

    Please attach your DxDiag.txt in a reply here. DxDiag.txt is generated by clicking the Windows Start Menu, typing dxdiag into the search field, selecting dxdiag.exe from the search results, and then clicking the Save All Information button in the dxdiag app.



  • yeah, I have the same problem, I’m on low/med settings, and getting 30-32 fps max and I still drop to 25 on a 64 man while a few friends are running perfectly at 60fps on the same server. I have 1400x900 resolution
    heres the full dxdiag.



  • Sorry, 1360 x 768

    See DxDiag.txt



  • Does this work for you? Us mods are still skeptical, but maybe worth a shot: viewtopic.php?f=5&t=10105



  • Yes, I have tried that. It does not work for ATI cards, apparently?

    EDIT/UPDATE

    The Optimizer WORKED. When the program was initially posted in the forums there was no Video Tutorial attached. Turns out I was linking the Optimizer to the wrong folder. If you’re in the same boat as I was make sure you select the right folder. Some people select the .exe. Don’t do this.

    It should just be the first chivalry folder you select in The common folder So you path should be
    c:\program files x86\steam\steamapps\common\chivalry: medieval warfare. That’s your path!

    I just jumped out of the game, I’m now getting 20 - 30+ frames more than I was before. Game runs great!

    EDIT/UPDATE 2

    It seems the boost in FPS has been sort lived. When I first ran the optimizer I had already had all the settings to low… The game seemed to be running great, when I went to bump up the resolution to my native setting (where it should be, everything is stretched the other way, but it was the only way to get decent frames), the menu screen was glitched when the picture came back. I restarted the game and picture was back to normal, however the FPS boost seems to have been lost. I tried reverting the settings back and rerunning the optimizer but now it doesn’t seem to do anything.



  • Same processor as you. Had terrible FPS before. OCed the processor to 3.4ghz. FPS doesnt go below 60.



  • I found zone alarm -> vsmon.exe had a 400mb ram leak. getting rid of that memory leak got my computer over the line in terms of performance. My current setup is a little low on ram :(. Game runs better now.



  • I have a hunch that the game doesn’t utilize the cores properly because not very many systems run with that many…



  • There is definetly something going on with the game. I have by no means a beast machine, but it is a quqd core AMD Phenom 4600, with 8gigs ram, and a brand new GTX660 SC that i have oced a little more and I cant get over 20 FPS in combat period. I have tried all tweaks on this forum, i have tried every possible combo of settings in game and in Nvidia Inspector. I can run BF3 on close to Ultra with 40-60FPS no matter what, several other games are the same. I also noticed that this game doesnt seem to tax the video card at all. When playing any other game with good graphics the card will get as hot as 72C but never breaks 45C with this game, leads me to believe that for some reason game is not utilizing all of the Video Cards power. What really kills me is that I get no difference in FPS from lowest settings to highest in game.


Log in to reply