[SOLVED] UDK.exe has stopped working



  • Hi guys,
    Just a bit confused, as I’ve been getting this message pop up whenever I try to start Chivalry. I’ve tried all the typical fixes, starting steam in Admin mode, reinstalling the game, deleting the config folder and revalidating, etc. Shall post my dxdiag, log, etc.

    I get past the torn banner and unreal loadup screens, but never any further! :(



  • It looks like it may be a problem with Visual C++ Redistributable. Kernelbase.dll is throwing the error, but let’s target MSVCR.

    From the .dmp callstack:

    >	msvcr100.dll!__getptd_noexit()  + 0x2a bytes	
    

    For thoroughness, uninstall anything that starts with “Microsoft Visual C++ 2010” x86/x64 reditributable/runtime/designtime. Then run the two vcredist executable files here: C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\RedistChiv



  • @ReMixx:

    For thoroughness, uninstall anything that starts with “Microsoft Visual C++ 2010” x86/x64 reditributable/runtime/designtime.

    Sorry to probably sound like an idiot, but where on my PC will I find them? I’ve ran a search and I can’t seem to find anything.



  • @Stubacca:

    @ReMixx:

    For thoroughness, uninstall anything that starts with “Microsoft Visual C++ 2010” x86/x64 reditributable/runtime/designtime.

    Sorry to probably sound like an idiot, but where on my PC will I find them? I’ve ran a search and I can’t seem to find anything.

    No worries. Click your start menu, and type in uninstall into the search field. From the search results, you should see a heading for Control Panel. Select either “Uninstall a Program” or “Programs and Features”. This will bring up the list of programs on your computer that you can uninstall. See the attached image. Look for the ones in the red highlighted box and uninstall them. You may not have all of the same ones that I have because I have Visual Studio 2010 installed.

    [attachment=0:3fr2s7ma]msvcr.png[/attachment:3fr2s7ma]



  • Yay!
    It’s working!
    Thank you! :)



  • @Stubacca:

    Yay!
    It’s working!
    Thank you! :)

    Awesome! I’m glad that it’s working for you! See ya on the battlefield. :k1:



  • I have the exect same problem, only, I had one C++ 2010 x86.
    I deleted it and it still is not working.
    It just says “UDK.exe is not responding”
    Please help. I REALLY want to play this game.
    :berz:



  • What are the negative impacts of uninstalling those c++ files?

    I’m running a crossfire connection of two 7770 sapphire radeon cards, and I have enough driver problems as it is. I’ve also tried the methods the OP has, but what do these files do that I’m uninstalling?


Log in to reply