Not able to join some servers.



  • Hello,

    Fitst off all, let me say that i already did “no servers in broswer” fix and iam able to join most of the servers. Iam from europe and i cant see many eu servers from game-monitor.com (especially the ones with people at night time). My friends from same country with same isp can find those servers normally in game browser and join them. Iam not able to follow them even via console (open ip:port). I always get “your connection to the server has been lost”. My connection is fine and i dont have firewall. Iam also not useing any router just cable modem.

    In other topic i found the guy with similar problem and mod told him this:

    @ReMixx:

    Please remove the line “Suppress=DevOnline” from your UDKEngine.ini (Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config). Then launch the game and try to connect to the server. After it times out, exit the game cleanly and then attach your Launch.log (Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs) in a reply here.

    So i did the same with the server that iam not able connect (same server worked for my friends).

    Have a nice day and sorry for my english ;).

    edit: Alternate server browser seems to be working but always connect me to random server (not the one ive clicked).



  • @virroo:

    Hello,

    Fitst off all, let me say that i already did “no servers in broswer” fix and iam able to join most of the servers. Iam from europe and i cant see many eu servers from game-monitor.com (especially the ones with people at night time). My friends from same country with same isp can find those servers normally in game browser and join them. Iam not able to follow them even via console (open ip:port). I always get “your connection to the server has been lost”. My connection is fine and i dont have firewall. Iam also not useing any router just cable modem.

    I hope that you are not trying to connect to the IPs listed by game-monitor.com. They provide the wrong port numbers.

    @virroo:

    In other topic i found the guy with similar problem and mod told him this:

    @ReMixx:

    Please remove the line “Suppress=DevOnline” from your UDKEngine.ini (Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config). Then launch the game and try to connect to the server. After it times out, exit the game cleanly and then attach your Launch.log (Documents\My Games\Chivalry Medieval Warfare\UDKGame\Logs) in a reply here.

    So i did the same with the server that iam not able connect (same server worked for my friends).

    Have a nice day and sorry for my english ;).

    edit: Alternate server browser seems to be working but always connect me to random server (not the one ive clicked).

    Thanks for letting me know. I thought that I fixed this, but it seems I did not get it completely (two threads were writing to the table at the same time). Did you happen to refresh it more than once after the initial refresh - did you click the refresh servers button?

    Your Launch.log shows you trying to connect to this server: 85.236.105.40:9287. I can’t connect to it. It doesn’t exist. Was it one of the ones from game-monitor.com?

    [0229.21] NetComeGo: Close IpNetDriverSteamworks_0 IpNetConnectionSteamworks_0 85.236.105.40:9287 02/19/13 05:42:13
    [0229.22] Log: GFullScreen End Movie -- 1
    [0229.22] Log: Pending connect to '85.236.105.40:9287/AOC-UDKFrontEndMap?Name=Player?Team=255' failed; Your connection to the host has been lost.
    [0229.22] Error: Can't destroy a null online session
    [0246.88] DevOnline: Steam IPC calls in the last minute: 0
    [0246.95] Exit: IpNetDriverSteamworks_0 shut down
    
    


  • Hey,

    Didnt know about wrong ports in game-monitor. But still my friends are able to see servers from gm in game browser and join them normally. So if the ports are wrong then lets ignore connecting from console. The thing is that i cant see some eu servers in game browser. Also Iam able to see and join them via alternate server browser. So its should be something wrong with game or steam.

    About your question, i think i connected after initial refresh. Then i connected after clicking stop and refresh again with some filters (did many attempts). Anyway i found the solution. First i try to find eu server with people then i write server name in filters section. So alternate server browser will find just one server i search for. Then i can join him without any problem and 100% acurate :).

    Anyway it would be nice to see those servers in game browser. Its jut weird, iam not able to see some of multiplay servers…official or not. Still most of them are visable.



  • @virroo:

    Hey,

    Didnt know about wrong ports in game-monitor. But still my friends are able to see servers from gm in game browser and join them normally. So if the ports are wrong then lets ignore connecting from console. The thing is that i cant see some eu servers in game browser. Also Iam able to see and join them via alternate server browser. So its should be something wrong with game or steam.

    About your question, i think i connected after initial refresh. Then i connected after clicking stop and refresh again with some filters (did many attempts). Anyway i found the solution. First i try to find eu server with people then i write server name in filters section. So alternate server browser will find just one server i search for. Then i can join him without any problem and 100% acurate :).

    Anyway it would be nice to see those servers in game browser. Its jut weird, iam not able to see some of multiplay servers…official or not. Still most of them are visable.

    Okay so you have a temporary working solution. I’m sorry that the Alternate Server Browser is not perfect yet… I’m still learning the intricacies of coding in multiple-threads in Java.

    Part of the reason why you may not see the servers that you want in the in-game server browser is that the server browser only queries the first 240 or so servers reported by the master server. If the servers that you want are not in those first 240, they won’t be queried. I would expect that to be changed at a later point as the devs optimize the server browser.

    Another thing that you can do is to add the servers to your in-game Favorites from outside of the game. You would need the exact name of the server which I think you can grab from the game-monitor.com website just fine.

    Open your UDKUI.ini (Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config) and scroll down to the section “[AOC.AOCView_Frontend_JoinGame]”.
    Add a line at the bottom with the EXACT name of the server as a Favorite. Here is an example to the server “Official Classic Server #01 [24p] - Multiplay”:

    FavoriteServers=Official Classic Server #01 [24p] - Multiplay
    

    So that would be on it’s own separate line under that heading. Add your server’s name like that. Then save the change, open the game and server browser, and go to the Favorites Tab. Wait for the 20 seconds and see if the server shows up in your favorites. If it does show up (meaning it successfully queried it), try joining! Please report back if this works :)


Log in to reply