5-10 second Lag Spikes every few minutes



  • People will keep running the same direction until they hit a wall, I can’t sprint, and everything seems to “catch up” after around 5 to 10 seconds. I’m usually dead when the spike is over.

    It happens on various servers with low and high pings, nor does there appear to be any difference in the duration or frequency of the lag spike. My ping usually averages between 50-70 ms.

    The issues seem to coincide with when I reinstalled windows since I upgraded to a SSD hard drive. I don’t know why this specific lag issue would come up, but that’s the only recent change I can account for. I’ve installed all windows and driver updates. I don’t have anything running in the background with the exception of steam of course.

    I’m sure there has to be at least a few more people having this issue. Any advice would be greatly appreciated. I love the game, but I can’t even sit down and play a full round of last team standing without dying to lag spikes.

    My specs:

    windows 7 Home Premium 64-bit
    Core i5-2400
    16GB ram
    Nvidia GeForce GTX 470



  • Do the lag spikes happen for any other multiplayer game?



  • This is probably because you’re running a 64-bit OS.
    I used to run Chivarly in 64-bit, and it lagged like hell, so I reformatted my PC to a 32-bit version of Windows 7 and it ran fine, averaging around 50-62fps.
    This game needs support for 64-bit systems.



  • Post patch I would invariably run into servers with this issue. Perhaps 20% of the time.

    However in the past week or more I have not seen it happen much.



  • Thanks for the replies. Arron, I don’t think it is related to my os being 64bit becaue Ive been playing on the same os since the game came out. Remixx, I assume you’re asking if it happens in different game types, and that’s something i’ll watch for when I play again. I mainly play last team standing. Gregcau, now that you mention it, this issue did seem to start right after the new patch. I will keep experimenting and update when I have some new information.

    Thanks again for the replies :)



  • I had been playing on the same 64-bit OS since the game came out too, but when the new patch came it started getting laggy.



  • Same here,
    Having lag spikes on most servers since last update,
    Never had any issues about that before…
    Weird.



  • Last night when the big “everything including steam died” spike hit I was on some official servers that exhibited this behavior.
    I think it was GER 02 or something like that.
    The weird thing is, almost everyone was under 100ms, yet we all suffered the lag spikes, with people suddenly popping up 3-4 seconds further ahead than before the lag spike.
    The ping always was fine, but the spikes persisted.

    There is also this weird kind of “map loading” lag at the start of maps sometimes, kind of like a light lag like stutter, before the map sort of settles in and just runs. I’ve had others confirm this as happening to them as well, regardless of their ping and server load.

    This is definitely something that should be looked into, if its traceable / reproduceable at all.



  • @SomeDudeOnAForum:

    Last night when the big “everything including steam died” spike hit I was on some official servers that exhibited this behavior.
    I think it was GER 02 or something like that.
    The weird thing is, almost everyone was under 100ms, yet we all suffered the lag spikes, with people suddenly popping up 3-4 seconds further ahead than before the lag spike.
    The ping always was fine, but the spikes persisted.

    There is also this weird kind of “map loading” lag at the start of maps sometimes, kind of like a light lag like stutter, before the map sort of settles in and just runs. I’ve had others confirm this as happening to them as well, regardless of their ping and server load.

    This is definitely something that should be looked into, if its traceable / reproduceable at all.

    I agree. I can’t see any correlation between players pings when it happens. My best guess is that something is happening server side - backup, download, something. But since I doubt anyone actually monitors these servers like a dedicated server admin I can’t see how it is going to get resolved.



  • I still haven’t been able to find any patterns in the lag spikes. Gregcau, I think you’re right about it being a server side issue. Yesterday was a little better. I actually got to play a couple of games with only 1 or 2 spikes.



  • I host a few servers, and had exactly this issue when running the server on windows server 2008 R2, switched to 2003 and had no problems at all, so it`s very possible it is something server side that is causing these lag spikes



  • This is getting worse and worse, with a lot of people complaining almost no matter where you go.
    Is this being addressed/looked into?



  • I haven’t heard of this specific issue being looked at. I have seen some intermittent improvements, however. I was able to play a few entire games with no spikes at all the other day. Now they’re back today. It’s very sporadic.


Log in to reply