Unable to Connect to Any Servers.



  • I registered to report a problem i have noticed come out of the blue to me and multiple other steam friends of mine for chivalry. We are unable to connect to any of the servers as it just sits at the please wait loading screen and it does nothing. I have tried to verify my cache but to no avail, hopefully there is a known fix to this or is a problem on the devs end. Thank you for your time in reading this and i hope things go well.



  • Indeed, I have the same problem. I play CMW for two weeks now, and I never had any connection problems. Now, I just can’t get on a server since the game make me wait ages on the server loading screen then tell me that the connection with the host has been lost…

    Really need help on that case, please !



  • Try this instead

    viewtopic.php?f=69&t=10664

    Works well and player counts are accurate.



  • Having the same problem as of today (March 01, 2013). I cannot connect to Official servers in Singapore #17, #18 and #19. It’s just an endless loop of “Please wait while the game loads”.



  • I fixed my issue by just restarting steam, hopefully this works out for the others. I do appreciate the help greg of posting down information for others.



  • I have the same issue, and even worse I live abroad in Asia which means there are very few servers to choose from to begin with.

    As it stands now, there are about 5 or 6 servers in my server browser that regularly have people on them with a ping less than 150 ms, but I am only able to join one of them, and to do so I have to wait about 3 to 5 minutes to connect (bizarre). And it’s a terrible server with horrible packet loss, which makes me never want to join it.

    At one point I was able to regularly join a Korean server (~100 ms), but now it always shows 0/64 players in the server browser (but if I click on “View Details”, I can clearly see that people are in the server). If I attempt to join the server, I am left waiting at the “connecting screen” indefinitely.

    Oddly enough I ran into someone on a small server recently who I recognized and asked him if he was able to join the Korean server I described above. He said it suddenly disappeared and he can no longer play there either.

    What is going on with the game’s server coding…??? It’s such a great game. What a pity it would be if it died just because nobody was able to actually, you know, play it!

    Can any of the devs please respond?

    TLDR: I am unable to play the game I purchased because it will not allow me to connect to the servers in the server browser. In addition, there are certain servers that I know exist (thanks to threads on this forum about official servers) which I was previously able to manually connect to using the “OPEN” command, but which do NOT display in my server browser. Also, using the “open” command no longer does anything, and I can no longer connect to those servers either. Help! :x



  • @Sir:

    Having the same problem as of today (March 01, 2013). I cannot connect to Official servers in Singapore #17, #18 and #19. It’s just an endless loop of “Please wait while the game loads”.

    This is my exact problem!


Log in to reply