Stuck on "loading please wait"



  • So I’ve never had any problems with this game in almost 200 hours played until tonight. Got online to play with some friends and it would not let me join a server. I can’t join on friends (Just sits on the menu) I can’t join via the console (Sits on the menu) and when I try to join from the server browser it just says “Loading please wait”. Has anyone found a fix for this?

    I’ve tried re-downloading the game.
    Tried rebooting.
    Tried disabling firewall/Antivirus.
    Tried verifying game integrity on steam.

    Any help would be greatly appreciated.

    EDIT: I forgot to mention. I seem to be able to join servers on DUEL mode. but nothing else. strange…

    Launch log below.



  • I have gone through and done all the fixes that are suggested to this thread, except reinstall which I will do tonight. The discussion about this has seemed to slow down. Im wondering if there are still as many people getting this error.



  • I’ve searched google for the last 2 hours, tried everything I found. Nothing seems to fix it. From what i’m seeing people have been having this problem since october. Strange that there is no official fix for it.



  • viewtopic.php?f=69&t=11371

    Check here.

    I get this from time to time on some servers but not often. Unreal Engine games seem a bit finikey when running through Steam and particular modems / routers.



  • Its nothing to do with my modem/router. This is the first time I’ve had this problem in over 200 hours played. Not only that but my brother plays as well in the same house. He was and still is playing the entire time I’ve been having this issue. On the same router/modem.



  • I’ve also stared encountering this problem today after 365 hours of play.

    Strangely for me, it only applies to Team Objective - and only multiplayer - single-player is fine but single-player is boring



  • It seems a large amount of people are having this problem tonight. I was able to get into a duel server (That is the ONLY server i could get into) and stayed in it until it switched to TO. For some strange reason I am able to join servers again. Wish I could tell you all a fix but I don’t know how it works now and didn’t earlier.



  • viewtopic.php?f=69&t=11492

    This guy may have cracked the code for a work around.