Unexplained Choppy FPS???



  • I don’t know about anybody else, but i was able to run this game at max settings with a steady 60-90fps. That was about a week and a half ago and now I’m getting choppy screen gameplay. Don’t know if it was a recent small parch or something but it really bothers me. :(



  • Validate the files maybe. Something could have gone wrong though unlikely.

    More likely is the installation of something else.

    Click the link in my sig. Might help.



  • When i said choppy fps, i simply ment that my performance had gone way down when i looked at high demanding scenes of maps, and my fps dropped drastically. This was odd to me considering that about a couple weeks ago this never happend and I experienced smooth gameplay at every corner of every map. :D



  • I just want to know how much that little texture compressor can do. If it can help with choppy FPS and dropped FPS as well.

    It still works on high end machines. It will still take the FPS up.

    And I swear the the unreal engine is capped at 90FPS. Need to ask about that.



  • I tried out the program that you suggested and it did relitively nothing. But it was worth a try. My fps is still dropping to about 45 which is making gameplay a bit choppy :(



  • @bishibosh:

    I tried out the program that you suggested and it did relitively nothing. But it was worth a try. My fps is still dropping to about 45 which is making gameplay a bit choppy :(

    Not sure what you mean choppy, I run at 40 FPS without choppyness - are you sure there is not a process running that is chewing at your hard drive e.g. crap like Google Index or Microsoft Indexing.



  • i have gtx670 and i5-3570k and im running max at 90 fps no problem except when i look at the wooden wall side at the citadel(?)

    why dont you just get a new graphics card? get a gtx 680. i will get a dual gtx 680 next week.



  • @boomandvibe:

    i have gtx670 and i5-3570k and im running max at 90 fps no problem except when i look at the wooden wall side at the citadel(?)

    why dont you just get a new graphics card? get a gtx 680. i will get a dual gtx 680 next week.

    I have a laptop with 680m, the graphics card isn’t the problem. I can run skyrim at max settings with the smoothest gameplay, same with battlefield 3. Its just something about this game that makes my performance drop, and its wierd because a couple of weeks ago my game was running pleasurably smooth and i was happy. My drivers are all the way updated.



  • I FOUND THE PROBLEM, AFTER THE PATCH SCREWED UP MY SETTINGS, I DIDNT SEE VSYNC WAS TOGGLED…… Mega Facepalm Sorry all
    :D



  • gtx 680m is not a good card. it’s slower than desktop 660 ti which is also not a very good card. sure its the best for laptop but you seriously should get a desktop for gaming.

    i dont know why vsync was making you lose frames. i have steady 60 with it on but i have a 144 hz monitor so i like 90 fps better.



  • @boomandvibe:

    gtx 680m is not a good card. it’s slower than desktop 660 ti which is also not a very good card. sure its the best for laptop but you seriously should get a desktop for gaming.

    i dont know why vsync was making you lose frames. i have steady 60 with it on but i have a 144 hz monitor so i like 90 fps better.

    You should seriously mind your own business, you don’t need to be making worthless suggestion to me like you know what’s best. My computer fufills what i play at max settings, and you tell me i need to upgrade? Lol. And I don’t know why vsync makes my comp. performance drop, but next time I’ll surely ask you for permission and recommindation sir! Cause you know best! :crest:



  • ok you are being too sensitive like a pmsing girl. im sorry if i made you mad because i dissed on your bad laptop which you probably spent 2000 dollars for shitty performance. you are gonna have to replace your entire laptop in a year and we will see who is crying. haha



  • @boomandvibe:

    ok you are being too sensitive like a pmsing girl. im sorry if i made you mad because i dissed on your bad laptop which you probably spent 2000 dollars for shitty performance. you are gonna have to replace your entire laptop in a year and we will see who is crying. haha

    Wow you are a complete dick aren’t you?



  • @elitenoob:

    @boomandvibe:

    ok you are being too sensitive like a pmsing girl. im sorry if i made you mad because i dissed on your bad laptop which you probably spent 2000 dollars for shitty performance. you are gonna have to replace your entire laptop in a year and we will see who is crying. haha

    Wow you are a complete dick aren’t you?

    Just a wanna be elitist!



  • @elitenoob:

    @boomandvibe:

    ok you are being too sensitive like a pmsing girl. im sorry if i made you mad because i dissed on your bad laptop which you probably spent 2000 dollars for shitty performance. you are gonna have to replace your entire laptop in a year and we will see who is crying. haha

    Wow you are a complete dick aren’t you?

    nah just that people are too preoccupied with being nice to each other like girls



  • @boomandvibe:

    ok you are being too sensitive like a pmsing girl. im sorry if i made you mad because i dissed on your bad laptop which you probably spent 2000 dollars for shitty performance. you are gonna have to replace your entire laptop in a year and we will see who is crying. haha

    You are funny sir, would you like a cookie for your accomplishment of achieving nothing? Clearly you have no people skills and will get nowhere in life. Cheers! ;)



  • Haha this thread took a funny turn :p
    Well V-Sync did drop my fps a lot too man.
    I just turned that and dynamic shadows off and its running pretty smooth.
    I should have payed 2000 though for a better pc :P



  • @bishibosh:

    I FOUND THE PROBLEM, AFTER THE PATCH SCREWED UP MY SETTINGS, I DIDNT SEE VSYNC WAS TOGGLED…… Mega Facepalm Sorry all
    :D

    Oh yeah. It maxed out all my srttings too. Took me 2 seconds to chane them though.



  • @trickshot:

    I just turned that and dynamic shadows off and its running pretty smooth.

    Doesn’t turning dynamic shadows off make your game really dark?



  • @Peacerer:

    @trickshot:

    I just turned that and dynamic shadows off and its running pretty smooth.

    Doesn’t turning dynamic shadows off make your game really dark?

    Turning off dynamic lighting makes it really dark.

    Turning off dynamic shadows turns off the shadows of units, projectiles and pushables


Log in to reply