[SOLVED] Any way to stop tearing without vsync?



  • My fps is capped at 60, never goes above/below, and yet I still get a massive amount of tearing. Vsync is synonymous with introducing mouse input delay and I definitely notice it when it’s on. So I’m wondering if there’s any way to stop tearing with using vsync.

    i5 3570k@4.4
    8gb DDR3 1600
    GTX670FTW(314.21)
    Windows 7
    1080p

    Any other info needed just say so. Thanks.



  • Why don’t I notice this input lag with vsync on? :(



  • @ReMixx:

    Why don’t I notice this input lag with vsync on? :(

    Not sure the exact reason, not everyone does feel it in the same way that some people are more sensitive to lower framerates than others I guess. It’s definitely linked, and confirmed to be so though. Also, with this game specifically, I notice that if you turn VSync on in the menu, it doesn’t actually activate until I alt+enter two times.



  • What if you uncap the framerate or set it ridiculously high like 120?



  • @ReMixx:

    What if you uncap the framerate or set it ridiculously high like 120?

    Eh, I had it capped to 120 initially. Guess I’ll just keep it at that. It’s a minor annoyance of mine, but not game breaking.



  • Does the framerate smoothing option have any effect on it? Just thinking out loud/guessing at this point :)



  • @ReMixx:

    Does the framerate smoothing option have any effect on it? Just thinking out loud/guessing at this point :)

    Hm, it did reduce tearing a bit, but not that much. But it seems I’ve found a solution for myself. Capped my FPS to 60 in UDKEngine.ini turned off vsync in game, turned on adaptive vsync in NVCC and there’s not a trace of tearing for me and no mouse lag oddly enough. I appreciate all the help ReMixx.



  • @venomblade:

    @ReMixx:

    Does the framerate smoothing option have any effect on it? Just thinking out loud/guessing at this point :)

    Hm, it did reduce tearing a bit, but not that much. But it seems I’ve found a solution for myself. Capped my FPS to 60 in UDKEngine.ini turned off vsync in game, turned on adaptive vsync in NVCC and there’s not a trace of tearing for me and no mouse lag oddly enough. I appreciate all the help ReMixx.

    Neat. Maybe this will prove useful for others :)


Log in to reply