Rank and Weapons Reset

  • I logged in to play today but my rank has been reset from 33 to 0, and all of my unlocked weapons are gone. I tried resetting the game, tried different servers, reset steam, reset computer, but I am still missing my unlocked. Anyone know what could be wrong?

  • Are you playing the beta?

    Try deleting the Chivalry directory from Documents\My Games.

  • No this is only for the regular version of the game. I haven’t even installed the beta.

    Interestingly, when I load the game on my laptop I am still rank 33 with all the unlocks. I tried playing a bit and then quit and switched back to my desktop, but I’m still in the same spot (level 0 no unlocks). I’ll try deleting the folder as you mentioned and get back.

  • Deleting the folder did not work.

    Complete re-install of the game did not work.

    Starting to get worried :S

    Edit: I just joined a new game on my laptop and instead of those settings overriding the others like I was hoping, I am now completely reset on my laptop as well (rank 0, no weapons). It seems like for whatever reason steam is overwriting my user files to show as rank 0.

    Edit 2: I’ve played a bit and things are progressing as if I’m starting fresh. Unlocked one of the Vanguard weapons and upon exiting and restarting the game, I still have that weapon. I have a feeling whatever is saved on my steam cloud was overwritten with the blank game data. Is there any way to reverse this?

  • It shouldn’t be possible for your stats to get completely reset. You might’ve been unlucky and just played at a time when the server wasn’t able to grab your stats and your game is just running off what it has saved locally. Maybe it’ll come back soonish? Try playing on a different server.

  • I logged in this morning on an official server and had the same results… My progress from yesterday is what I had (level 3 and one weapon unlocked).

    If it couldn’t connect to the server it wouldn’t make sense that my laptop would have its settings overwritten to show no unlocks and level 0 AFTER it was showing me at 33 with all unlocks (this was after the problem was initially occurring on my desktop). I strongly believe that the steam cloud thinks I’m at level 3.

    Edit: Not sure if anyone is still reading this but the issue is still not fixed. I managed to unlock the primaries for Vanguard again and am at level 10, but no luck getting my old rank back. I’ve also been hearing many stories of people getting mysteriously ranked up or down many levels and keeping those changes. Can someone please look into this?

Log in to reply